Permalink
Browse files

update readme

  • Loading branch information...
1 parent 085223e commit 01ce3a727862eb7e85e60f2bd2687b44d620a4fb @klacointe committed Jan 8, 2010
Showing with 24 additions and 3 deletions.
  1. +1 −0 .document
  2. +22 −0 README.rdoc
  3. +1 −3 Rakefile
View
@@ -3,3 +3,4 @@ lib/**/*.rb
bin/*
features/**/*.feature
LICENSE
+generators/**/*.rb
View
@@ -2,10 +2,32 @@
Media Managment Library for ActiveRecord and Carrierwave
+Easy way to link media (ie image, audio, pdf for now) on other activerecords models
+
=== Create migrations
./script/generate has_media
+== Usage
+
+ has_one_medium :image, :only => :image
+ has_many_media :images, :only => :image
+
+ has_one_medium :audio, :only => :audio
+ has_many_media :audios, :only => :audio
+
+ has_one_medium :image_no_encode, :only => :image, :encode => false
+
+ has_one_medium :pdf, :encode => false
+
+== TODO
+
+* Add a video class
+
+== Contributors
+
+klacointe, spk, shingara, nono
+
== Copyright
Copyright (c) 2009 AF83. See LICENSE for details.
View
@@ -8,15 +8,13 @@ begin
gem.summary = %Q{Media Managment Library for ActiveRecord and Carrierwave}
gem.description = %Q{Media Managment Library for ActiveRecord and Carrierwave}
gem.email = "kevinlacointe@gmail.com"
- gem.homepage = "http://github.com/klacointe/has_media"
+ gem.homepage = "http://github.com/AF83/has_media"
gem.authors = ["klacointe", "spk"]
gem.add_development_dependency "rspec", ">= 1.2.9"
gem.add_dependency('carrierwave', '>=0.4.2')
gem.add_dependency('activerecord', '>=2.3.4')
gem.add_dependency('activesupport', '>=2.3.4')
# gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
- gem.files = FileList['LICENCE', 'README.rdoc', 'Rakefile', 'VERSION',
- 'lib/**/*.rb', 'spec/**/*', 'generators/**/*.rb'].to_a
end
rescue LoadError
puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"

0 comments on commit 01ce3a7

Please sign in to comment.