Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

knex CLI doesn't work in latest release #1587

Closed
tdboone opened this issue Jul 21, 2016 · 4 comments
Closed

knex CLI doesn't work in latest release #1587

tdboone opened this issue Jul 21, 2016 · 4 comments

Comments

@tdboone
Copy link

@tdboone tdboone commented Jul 21, 2016

The knex CLI doesn't appear to be working since the latest release. I think the bin attribute in package.json was removed inadvertently: https://github.com/tgriesser/knex/pull/1578/files#diff-b9cfc7f2cdf78a7f4b91a753d10865a2L63

@elhigu
Copy link
Member

@elhigu elhigu commented Jul 21, 2016

Uh, I should have spotted that. And once again I think we need some test case for client, this is not the first time it breaks silently and it is not spotted before release. Maybe some test should read where bin is pointing in package.json and try running that... maybe

@elhigu
Copy link
Member

@elhigu elhigu commented Jul 21, 2016

I'll roll out 0.11.9 shortly

@elhigu
Copy link
Member

@elhigu elhigu commented Jul 21, 2016

@tdboone I released 0.11.9 where that change is reverted, let me know if there are still problems

@tdboone
Copy link
Author

@tdboone tdboone commented Jul 21, 2016

The CLI is working again in 0.11.9. Thank you!

@tdboone tdboone closed this Jul 21, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.