gemspec date error #3

Closed
sreid99 opened this Issue Jul 7, 2011 · 4 comments

Comments

Projects
None yet
3 participants
@sreid99

sreid99 commented Jul 7, 2011

I'm trying to install the latest mechanize gem. However it has a dependency on webrobots 0.0.10, and I'm getting an error when trying to install with bundler.

.../webrobots-0.0.10.gemspec]: invalid date format in specification: "2011-07-01 00:00:00.000000000Z

@knu

This comment has been minimized.

Show comment Hide comment
@knu

knu Jul 7, 2011

Owner

I think this is a compatibility bug in rubygems.
http://help.rubygems.org/search?q=000000000Z&t=d&scope=all&category_id=&recommend=1

What is the version of rubygems you are using?

I created the gem with ruby-1.9.2p274 and rubygems 1.8.5, both of which were the latest versions at that time.

Owner

knu commented Jul 7, 2011

I think this is a compatibility bug in rubygems.
http://help.rubygems.org/search?q=000000000Z&t=d&scope=all&category_id=&recommend=1

What is the version of rubygems you are using?

I created the gem with ruby-1.9.2p274 and rubygems 1.8.5, both of which were the latest versions at that time.

@sreid99

This comment has been minimized.

Show comment Hide comment
@sreid99

sreid99 Jul 7, 2011

I was on ruby 1.8.7p334 and rubygems 1.7.2.

I updated rubygems to 1.8.5 and it's now working.

Thanks

sreid99 commented Jul 7, 2011

I was on ruby 1.8.7p334 and rubygems 1.7.2.

I updated rubygems to 1.8.5 and it's now working.

Thanks

@treeder

This comment has been minimized.

Show comment Hide comment
@treeder

treeder Nov 14, 2011

We were still seeing this with rubygems 1.8.11, but I'm curious if you're most recent update (which was only a new gemspec and version bump) was to fix this issue?

treeder commented Nov 14, 2011

We were still seeing this with rubygems 1.8.11, but I'm curious if you're most recent update (which was only a new gemspec and version bump) was to fix this issue?

@knu

This comment has been minimized.

Show comment Hide comment
@knu

knu Mar 17, 2013

Owner

Recent versions of rubygems do not seem to have this problem any more.

Owner

knu commented Mar 17, 2013

Recent versions of rubygems do not seem to have this problem any more.

@knu knu closed this Mar 17, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment