Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

CHANNEL GROUP ISSUE #111

Closed
dellas60 opened this issue Oct 12, 2018 · 72 comments

Comments

Projects
None yet
3 participants
@dellas60
Copy link

commented Oct 12, 2018

I cant get channel group on windows version

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 12, 2018

Can you provide more information and a debug log including the addon version number?

@dellas60

This comment has been minimized.

Copy link
Author

commented Oct 12, 2018

thanks for reply ,i can get my group channel from my e2 device,i get only all channels when select group

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 12, 2018

What version of Kodi are you using and what version is the addon?

@dellas60

This comment has been minimized.

Copy link
Author

commented Oct 12, 2018

kodi 18 BETA 4 GIT 10102018 ADDON VERSION 3.12.3

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 12, 2018

@dellas60

This comment has been minimized.

Copy link
Author

commented Oct 12, 2018

No,i cant get my channel groups from my backend device

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 12, 2018

Can you post your settings.xml from the addon?

Should be be at userdata/addon_data/pvr.vuplus/settings.xml

@dellas60

This comment has been minimized.

Copy link
Author

commented Oct 12, 2018

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 12, 2018

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 12, 2018

@dellas60

This comment has been minimized.

Copy link
Author

commented Oct 12, 2018

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 12, 2018

Thanks, just making sure you have groups being sent. In order to help you further I will need your debug log. The log above is not a debug log.

You can use pastebinit to provide a short link to it. This make's the issue much easier to read. Thanks

@dellas60

This comment has been minimized.

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 13, 2018

Ok, your last post was finally a debug log. Unfortunately it stops while still loading channels. I can see that every group is loaded though.

Is it possible that because you have so many channels it takes a long long time to load?

I would need to see a log up to it completing a full EPG load.

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 13, 2018

You also appear to have a channel for each movie. That makes a lot of channels.

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 13, 2018

Anyway you can limit your STB to only 2/3 groups? It might make it easier to figure out what’s happening.

@M2k80

This comment has been minimized.

Copy link

commented Oct 18, 2018

only for information. just added a groud to my channellist and know i have no more groups in kodi
i have now 6 groups and one of this is radio favorites. kodi does list now 174 channels and only one group called all channels.

all was fine until i added today 1 more group
/edit: delete this group again did not fix the problem

/edit2:
ok, here my debug log.
https://paste.ubuntu.com/p/WSS6mzSK52/

/edit3:
ok on kodi build git: 20181009-55f4765d5d its working again compiled on Oct 10
all later build wont work

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 18, 2018

Hmmm, it looks like for some reason you are not getting any groups. For each channel no group was found:

21:12:09.192 T:1924 DEBUG: AddOnLog: Enigma2 Client: pvr.vuplus - Enigma2::GetInitialEPGForChannel Checking for initialEPG for group '', num groups 4, channel Sky Sport Bundesliga 6

The group name should be displayed inside the quotes ('').

I'm travelling with work currently. Once I get home I'll look into this. I should hopefully be able to replicate. Might ping you for more info if I can't. Not back till the end of the month.

@M2k80

This comment has been minimized.

Copy link

commented Oct 18, 2018

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 18, 2018

Yes, that will help, however I can't test any fix until I am home as I don't have an STB with me. I'm sure the fix will be easy enough.

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 18, 2018

What was the version of the addon for the one which last worked? That will help me find this.

The last time the Group code was changed before that so doesn't make sense in that timeline.

@M2k80

This comment has been minimized.

Copy link

commented Oct 18, 2018

@M2k80

This comment has been minimized.

Copy link

commented Oct 18, 2018

3.12.2 is working

@dellas60

This comment has been minimized.

Copy link
Author

commented Oct 18, 2018

same problem with 3.12.4

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 19, 2018

Makes sense no change to that code since 3.12.2, I should be able to figure it out from here. Should have a fix in about 10 days.

@dellas60

This comment has been minimized.

Copy link
Author

commented Oct 19, 2018

OK,THANKS

@M2k80

This comment has been minimized.

Copy link

commented Oct 19, 2018

just something funny, i installed a clean version of latest kodi and only enabled the pvr plugin and all groups are there. idk why
is there any cache files or settings i can delete for testing in my default kodi to get the groups maybe back?

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 19, 2018

@M2k80

This comment has been minimized.

Copy link

commented Oct 19, 2018

@dellas60

This comment has been minimized.

Copy link
Author

commented Oct 19, 2018

from official kodi site

@dellas60

This comment has been minimized.

Copy link
Author

commented Oct 19, 2018

source of build for kodi or vu+ addon

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 19, 2018

@dellas60

This comment has been minimized.

Copy link
Author

commented Oct 19, 2018

KodiSetup-20181018-a6c1a4f4-master-x64

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 19, 2018

That's the latest, they may only update the addons occasionally.

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 19, 2018

If there is forum thread for the windows x64 Leia builds you could ask there.

@M2k80

This comment has been minimized.

Copy link

commented Oct 19, 2018

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 19, 2018

Hmmm, have you tried the latest nightly from here: http://mirrors.kodi.tv/nightlies/android/

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 19, 2018

Although there is no way to tell if it has the latest addons without installing it.

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 20, 2018

@M2k80

This comment has been minimized.

Copy link

commented Oct 20, 2018

kodi apk was allways shipped with complete binary addons inside, now the binary addons are splittet into the repo, thats why the build is now only 60mb instead of 90mb.

the build i used for the clean install is from kodinerds.de but has binary addons included, so repo is not needed.

actually with the repo seems something wrong, ex. the input_stream addon is missing, too and your pvr plugin is on 3.12.4. instead of 3.12.6

i just compile again my own build with binary addons included again and will see which version of pvr.vuplus is included

@M2k80

This comment has been minimized.

Copy link

commented Oct 20, 2018

ok my build is done...deleted all folders and build from scratch - on my build before, it seems not all files from the binary-addons where updated, thats why it stay on 3.12.4.
now it has pvr.vuplus 3.12.6 included, so there must be something wrong with the repo. AND i got the input_stream addon back, that wasn included on the repo anymore

and finaly my groups are working again.

so for all others, you have to wait until the repo is fixed and pvr.vuplus is updated to the latest version

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 20, 2018

@M2k80

This comment has been minimized.

Copy link

commented Oct 20, 2018

i allways build normaly my own build from offical github sources, because i cant wait for the latest commits.
and kodinerds.de is a trusted source for me, its a german community about kodi, one of team kodi members, peak3d is also there to help the people here, and i know the guy who made the builds.
these builds are 100% identical to the github, the only change is, that the org.xbmc.kodi folder is renamed to org.xbmc.kodinerds, so you can have 2 kodi builds installed for example testing

@M2k80

This comment has been minimized.

Copy link

commented Oct 20, 2018

but to make the group problem clear.
the problem is fixed with 3.12.6
but kodi repo just uses an old version, and we have to wait until its updated and the repo is fixed.

so i am fine now with your plugin.
you make a good job here, i think its not only me, but you make many e2 users happy with your work on this plugin

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 20, 2018

Ah, I didn’t know that was the case with kodinerds!

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 20, 2018

You’re very welcome 😉

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 20, 2018

@dellas60 looks like you'll have to wait until the nightlies catch up on the versions unless you want to try building kodi yourself.

I'll leave the issue open until you can verify the fix also.

@M2k80

This comment has been minimized.

Copy link

commented Oct 21, 2018

@dellas60 i just tested with latest windows build, pvr.vuplus is now on 3.12.6, so it should be on latest android too

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 21, 2018

Fingers crossed this is a bug that is not a bug 😉

@Mk280 I assume channel groups still work correctly in this windows build?

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 21, 2018

For you both. One of the next changes will be to tackle #101. This will mean changing a lot of the group and channel code but should give a huge performance boost to users with older STBs. I’ll let you know when it’s ready and if you could verify that would be a great help. It’s a few weeks away from being ready.

@M2k80

This comment has been minimized.

Copy link

commented Oct 21, 2018

@dellas60

This comment has been minimized.

Copy link
Author

commented Oct 21, 2018

Thanks,the problem of channel group fixed,but epg scan is very low

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 21, 2018

I assume you mean slow. It may just be the initial load.

@M2k80, is it slow for you?

Regardless it should speed up again after I complete #101

@M2k80

This comment has been minimized.

Copy link

commented Oct 22, 2018

hmm i tried under windows and android...for me its fast as it never was.
on the old version befor your changes it take some time on every start, but now maybe 1 sek to finish

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 22, 2018

@M2k80

This comment has been minimized.

Copy link

commented Oct 22, 2018

epg load is very much faster as before

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 22, 2018

@phunkyfish

This comment has been minimized.

Copy link
Member

commented Oct 22, 2018

Closing as this is now resolved.

@phunkyfish phunkyfish closed this Oct 22, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.