Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

Npm install warnings #35

Open
KrzysztofMadejski opened this issue Dec 8, 2017 · 1 comment

Comments

@KrzysztofMadejski
Copy link
Member

commented Dec 8, 2017

There are some npm install warnings that could be resolved:

npm WARN deprecated babel-preset-es2015@6.24.1: 馃檶  Thanks for using Babel: we recommend using babel-preset-env now: please read babeljs.io/env to update! 
npm WARN deprecated gulp-webpack@1.5.0: Renamed to https://www.npmjs.com/package/webpack-stream
npm WARN factchecker-plugin-chrome@0.1.18 license should be a valid SPDX license expression

Also there are some warnings regarding dependencies of "babel-preset-react": "^6.5.0", "babel-preset-react-hmre": "^1.1.0", but I think they are not used, as react hasn't been used. Am I right @voidberg?

Warnings:

npm WARN redbox-react@1.5.0 requires a peer of react@^0.14.0 || ^15.0.0 || ^16.0.0-beta || ^16.0.0 but none was installed.
npm WARN redbox-react@1.5.0 requires a peer of react-dom@^0.14.0 || ^15.0.0 || ^16.0.0-beta || ^16.0.0 but none was installed.

React is mentioned in following places: https://github.com/TransparenCEE/factchecker-plugin-chrome/search?q=react&type=Code&utf8=%E2%9C%93

@voidberg

This comment has been minimized.

Copy link

commented Dec 8, 2017

Need to double check, I think those are used for the airbnb eslint rules but there should be a non-react version.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can鈥檛 perform that action at this time.