Fix package.json to support node 0.8.x #58

Closed
kangax opened this Issue Sep 2, 2012 · 2 comments

2 participants

@kangax

It appears that >= 0.6.x <= 0.8.x doesn't allow npm to install qunit on, say, 0.8.7.

> node -v
v0.8.7

> npm install qunit@0.5.7
npm http GET https://registry.npmjs.org/qunit/0.5.7
npm http 304 https://registry.npmjs.org/qunit/0.5.7

npm ERR! Unsupported
npm ERR! Not compatible with your version of node/npm: qunit@0.5.7
npm ERR! Required: {"node":">= 0.6.x <= 0.8.x"}
npm ERR! Actual:   {"npm":"1.1.23","node":"0.8.7"}
npm ERR! 
npm ERR! System Darwin 11.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "qunit@0.5.7"
npm ERR! cwd /Users/kangax
npm ERR! node -v v0.8.7
npm ERR! npm -v 1.1.23
npm ERR! code ENOTSUP
npm ERR! message Unsupported
npm ERR! errno {}
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /Users/kangax/npm-debug.log
npm not ok
@kof
Owner
kof commented Sep 2, 2012

sounds like an npm bug, isn't it?

@kangax
@kof kof closed this in fce06bd Sep 3, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment