error installing via npm #6

Closed
weepy opened this Issue Oct 14, 2010 · 7 comments

Projects

None yet

3 participants

@weepy

output is below :

gcc -std=gnu99 -Ijs -Ijs/obj -DXP_UNIX -g -O2 -o generate-resources generate-resources.o

./generate-resources jscoverage-help.txt jscoverage-server-help.txt jscoverage.jsm jscoverage.manifest jscoverage.xul jscoverage-overlay.js jscoverage.html jscoverage.css jscoverage-ie.css jscoverage-highlight.css jscoverage.js report.js jscoverage-throbber.gif > resources.c
make all-recursive
Making all in js
make -f Makefile.ref DISABLE_JIT=1 OBJROOT=obj BUILD_OPT=1
Makefile.ref:61: disabling JIT per build specification
cd editline; make -f Makefile.ref all
make[5]: Nothing to be done for all'.
make -f Makefile.ref ./obj/libjs.a ./obj/libjs.dylib ./obj/js
Makefile.ref:61: disabling JIT per build specification
make[5]:
obj/libjs.a' is up to date.
make[5]: obj/libjs.dylib' is up to date.
make[5]:
obj/js' is up to date.
gcc -std=gnu99 -DHAVE_CONFIG_H -I. -Ijs -Ijs/obj -DXP_UNIX -g -O2 -MT encoding.o -MD -MP -MF .deps/encoding.Tpo -c -o encoding.o encoding.c
mv -f .deps/encoding.Tpo .deps/encoding.Po
gcc -std=gnu99 -DHAVE_CONFIG_H -I. -Ijs -Ijs/obj -DXP_UNIX -g -O2 -MT highlight.o -MD -MP -MF .deps/highlight.Tpo -c -o highlight.o highlight.c
In file included from js/jscntxt.h:49,
from highlight.h:23,
from highlight.c:22:
js/jsatom.h:69: error: size of array ‘arg’ is negative
In file included from js/jsgc.h:48,
from js/jscntxt.h:52,
from highlight.h:23,
from highlight.c:22:
js/jsbit.h:210: error: size of array ‘arg’ is negative
make[3]: *** [highlight.o] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all] Error 2
make: *** [jscoverage] Error 2
npm info qunit@0.0.4 Failed to exec install script
npm ERR! install failed Error: qunit@0.0.4 install: make install
npm ERR! install failed sh failed with 2
npm ERR! install failed at ChildProcess. (/usr/local/lib/node/.npm/npm/0.2.3-6/package/lib/utils/exec.js:24:18)
npm ERR! install failed at ChildProcess.emit (events:27:15)
npm ERR! install failed at ChildProcess.onexit (child_process:151:12)
npm ERR! install failed at node.js:768:9
npm info install failed rollback
npm info not installed qunit,0.0.4
npm info install failed rolled back
npm ERR! Error: qunit@0.0.4 install: make install
npm ERR! sh failed with 2
npm ERR! at ChildProcess. (/usr/local/lib/node/.npm/npm/0.2.3-6/package/lib/utils/exec.js:24:18)
npm ERR! at ChildProcess.emit (events:27:15)
npm ERR! at ChildProcess.onexit (child_process:151:12)
npm ERR! at node.js:768:9
npm ERR!
npm ERR! Failed at the qunit@0.0.4 install script.
npm ERR! This is most likely a problem with the qunit package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! make install
npm ERR! You can get their info via:
npm ERR! npm owner ls qunit
npm ERR! There may be additional logging output above.
npm not ok

@tisba

same problem here

@kof
Owner

seems like jscoverage installer makes problems ... does anybody know how to fix it?

@kof
Owner
kof commented Nov 1, 2010

I hope last changes has fixed the issue, can sobody please confirm the fix?

981954a

ae822ff

6624901

d778ffd

@tisba

Still failing for me. See http://gist.github.com/658333

@kof
Owner
kof commented Nov 1, 2010

just a moment I didn't updated npm, you are too fast :)

@kof
Owner
kof commented Nov 1, 2010

so now it is in npm

@kof
Owner
kof commented Nov 2, 2010

fixed installation process. Closed by f9a7dc6.

This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment