Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Highlighting does not work when subviews are added to contentView #113

Open
MegaJiXiang opened this Issue Mar 22, 2012 · 5 comments

Comments

Projects
None yet
3 participants
Contributor

MegaJiXiang commented Mar 22, 2012

When I click on cells, they turn blue. If I add a subview to the contentView of a cell, this blue highlight will not appear. Badges, however, appear correctly.

jonsterling added a commit that referenced this issue Mar 22, 2012

Merge pull request #114 from MegaJiXiang/master
Fixes issue #113 highlighting problem

After this fix, when I add anything to the contentView of a cell, it is covered when the cell is selected (another UIView, UILabel, etc).

Collaborator

jonsterling commented Mar 28, 2012

Oh dear, I didn't notice that when I merged it in. Sorry about that.

If I get a moment, I'll try and fix that; otherwise, feel free to submit a pull request referencing this issue if you figure it out before then.

Contributor

MegaJiXiang commented Mar 28, 2012

You have to set the highlight alpha to something other than 1.0

-Jody

On Mar 28, 2012, at 9:54 AM, Jonathan Sterlingreply@reply.github.com wrote:

Oh dear, I didn't notice that when I merged it in. Sorry about that.

If I get a moment, I'll try and fix that; otherwise, feel free to submit a pull request referencing this issue if you figure it out before then.


Reply to this email directly or view it on GitHub:
#113 (comment)

While that might work in some situations, it isn't ideal. That still leaves the contentView of the cell behind the _selectedBackgroundView. I just sent the _selectedBackgroundView back to the back....the way it used to be.

Contributor

MegaJiXiang commented Mar 29, 2012

So what's the point of a view which is supposed to show you selecting something that you can't see?

On Mar 28, 2012, at 11:38 AM, BLWedge09 wrote:

While that might work in some situations, it isn't ideal. That still leaves the contentView of the cell behind the _selectedBackgroundView. I just sent the _selectedBackgroundView back to the back....the way it used to be.


Reply to this email directly or view it on GitHub:
#113 (comment)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment