Skip to content
Permalink
Browse files

remove view_renderer chain assigment (#134)

* assign @context.view_renderer without .dup
* Run tests against rails 6.0.0.beta3
* Travis config: add rails 6 gemfile
* Use bundle 2.0 for Rails 6 gemfile
* Travis: force installing bundler 2.0.1
* Travis: move bundler install to before_install
* Update rails 6 gemfile.lock
* Drop support for Ruby 2.3
* Drop support for Ruby 2.4
* Update Changelog
  • Loading branch information...
agungyuliaji authored and Spone committed Mar 28, 2019
1 parent 8fbc872 commit 3aed17227e1a9d89586bc61905f304fa202b74b3
Showing with 68 additions and 64 deletions.
  1. +1 −1 .rubocop.yml
  2. +3 −3 .travis.yml
  3. +1 −1 Appraisals
  4. +2 −0 CHANGELOG.md
  5. +1 −1 README.md
  6. +1 −1 gemfiles/rails_6.0.x.gemfile
  7. +57 −55 gemfiles/rails_6.0.x.gemfile.lock
  8. +1 −1 komponent.gemspec
  9. +1 −1 lib/komponent/component_renderer.rb
@@ -1,5 +1,5 @@
AllCops:
TargetRubyVersion: 2.2
TargetRubyVersion: 2.5
DisabledByDefault: true
Exclude:
- node_modules/**/*
@@ -3,24 +3,24 @@ sudo: false

before_install:
- gem update --system
- gem install bundler

rvm:
- 2.3
- 2.4
- 2.5
- 2.6
- ruby-head

gemfile:
- gemfiles/rails_5.0.x.gemfile
- gemfiles/rails_5.1.x.gemfile
- gemfiles/rails_5.2.x.gemfile
- gemfiles/rails_6.0.x.gemfile

cache:
bundler: true
yarn: true

install:
- gem install bundler
- bundle install
- nvm install node
- node -v
@@ -11,5 +11,5 @@ appraise "rails-5.2.x" do
end

appraise "rails-6.0.x" do
gem "rails", "~> 6.0.0.beta1"
gem "rails", "~> 6.0.0.beta3"
end
@@ -3,6 +3,7 @@
## Upcoming release

**Breaking changes:**
- Dropped support for Ruby 2.3 and 2.4
- It's now recommended to use eager loading to prevent `uninitialized component` issues
(see [#121](https://github.com/komposable/komponent/issues/121) for background).

@@ -15,6 +16,7 @@
config.paths.add "frontend/components", eager_load: true

**Enhancements:**
- Support for Rails 6
- Refactoring to use `Utils` in `InstallGenerator` and prevent code duplication

## v3.0.0.beta1 (2019-02-28)
@@ -48,7 +48,7 @@ This gem has been inspired by our Rails development practices at [Ouvrages](http

## Compatibility

- Ruby 2.3+
- Ruby 2.5+
- Rails 5.0+
- Webpacker 3.0.0+

@@ -2,7 +2,7 @@

source "https://rubygems.org"

gem "rails", "~> 6.0.0.beta1"
gem "rails", "~> 6.0.0.beta3"
gem "rake", ">= 11.1"
gem "rubocop", require: false
gem "webpacker"
@@ -1,7 +1,7 @@
PATH
remote: ..
specs:
komponent (2.2.0)
komponent (3.0.0.beta1)
actionview (>= 5.0)
activesupport (>= 5.0)
railties (>= 5.0)
@@ -10,59 +10,60 @@ PATH
GEM
remote: https://rubygems.org/
specs:
actioncable (6.0.0.beta1)
actionpack (= 6.0.0.beta1)
actioncable (6.0.0.beta3)
actionpack (= 6.0.0.beta3)
nio4r (~> 2.0)
websocket-driver (>= 0.6.1)
actionmailbox (6.0.0.beta1)
actionpack (= 6.0.0.beta1)
activejob (= 6.0.0.beta1)
activerecord (= 6.0.0.beta1)
activestorage (= 6.0.0.beta1)
activesupport (= 6.0.0.beta1)
actionmailbox (6.0.0.beta3)
actionpack (= 6.0.0.beta3)
activejob (= 6.0.0.beta3)
activerecord (= 6.0.0.beta3)
activestorage (= 6.0.0.beta3)
activesupport (= 6.0.0.beta3)
mail (>= 2.7.1)
actionmailer (6.0.0.beta1)
actionpack (= 6.0.0.beta1)
actionview (= 6.0.0.beta1)
activejob (= 6.0.0.beta1)
actionmailer (6.0.0.beta3)
actionpack (= 6.0.0.beta3)
actionview (= 6.0.0.beta3)
activejob (= 6.0.0.beta3)
mail (~> 2.5, >= 2.5.4)
rails-dom-testing (~> 2.0)
actionpack (6.0.0.beta1)
actionview (= 6.0.0.beta1)
activesupport (= 6.0.0.beta1)
actionpack (6.0.0.beta3)
actionview (= 6.0.0.beta3)
activesupport (= 6.0.0.beta3)
rack (~> 2.0)
rack-test (>= 0.6.3)
rails-dom-testing (~> 2.0)
rails-html-sanitizer (~> 1.0, >= 1.0.2)
actiontext (6.0.0.beta1)
actionpack (= 6.0.0.beta1)
activerecord (= 6.0.0.beta1)
activestorage (= 6.0.0.beta1)
activesupport (= 6.0.0.beta1)
actiontext (6.0.0.beta3)
actionpack (= 6.0.0.beta3)
activerecord (= 6.0.0.beta3)
activestorage (= 6.0.0.beta3)
activesupport (= 6.0.0.beta3)
nokogiri (>= 1.8.5)
actionview (6.0.0.beta1)
activesupport (= 6.0.0.beta1)
actionview (6.0.0.beta3)
activesupport (= 6.0.0.beta3)
builder (~> 3.1)
erubi (~> 1.4)
rails-dom-testing (~> 2.0)
rails-html-sanitizer (~> 1.0, >= 1.0.3)
activejob (6.0.0.beta1)
activesupport (= 6.0.0.beta1)
activejob (6.0.0.beta3)
activesupport (= 6.0.0.beta3)
globalid (>= 0.3.6)
activemodel (6.0.0.beta1)
activesupport (= 6.0.0.beta1)
activerecord (6.0.0.beta1)
activemodel (= 6.0.0.beta1)
activesupport (= 6.0.0.beta1)
activestorage (6.0.0.beta1)
actionpack (= 6.0.0.beta1)
activerecord (= 6.0.0.beta1)
activemodel (6.0.0.beta3)
activesupport (= 6.0.0.beta3)
activerecord (6.0.0.beta3)
activemodel (= 6.0.0.beta3)
activesupport (= 6.0.0.beta3)
activestorage (6.0.0.beta3)
actionpack (= 6.0.0.beta3)
activerecord (= 6.0.0.beta3)
marcel (~> 0.3.1)
activesupport (6.0.0.beta1)
activesupport (6.0.0.beta3)
concurrent-ruby (~> 1.0, >= 1.0.2)
i18n (>= 0.7, < 2)
minitest (~> 5.1)
tzinfo (~> 1.1)
zeitwerk (~> 1.3, >= 1.3.1)
appraisal (2.2.0)
bundler
rake
@@ -78,7 +79,7 @@ GEM
backports (3.11.4)
builder (3.2.3)
childprocess (1.0.0)
concurrent-ruby (1.1.4)
concurrent-ruby (1.1.5)
contracts (0.16.0)
coveralls (0.7.1)
multi_json (~> 1.3)
@@ -114,7 +115,7 @@ GEM
activesupport (>= 4.2.0)
http-cookie (1.0.3)
domain_name (~> 0.5)
i18n (1.5.3)
i18n (1.6.0)
concurrent-ruby (~> 1.0)
jaro_winkler (1.5.2)
json (2.1.0)
@@ -148,29 +149,29 @@ GEM
rack
rack-test (1.1.0)
rack (>= 1.0, < 3)
rails (6.0.0.beta1)
actioncable (= 6.0.0.beta1)
actionmailbox (= 6.0.0.beta1)
actionmailer (= 6.0.0.beta1)
actionpack (= 6.0.0.beta1)
actiontext (= 6.0.0.beta1)
actionview (= 6.0.0.beta1)
activejob (= 6.0.0.beta1)
activemodel (= 6.0.0.beta1)
activerecord (= 6.0.0.beta1)
activestorage (= 6.0.0.beta1)
activesupport (= 6.0.0.beta1)
rails (6.0.0.beta3)
actioncable (= 6.0.0.beta3)
actionmailbox (= 6.0.0.beta3)
actionmailer (= 6.0.0.beta3)
actionpack (= 6.0.0.beta3)
actiontext (= 6.0.0.beta3)
actionview (= 6.0.0.beta3)
activejob (= 6.0.0.beta3)
activemodel (= 6.0.0.beta3)
activerecord (= 6.0.0.beta3)
activestorage (= 6.0.0.beta3)
activesupport (= 6.0.0.beta3)
bundler (>= 1.3.0)
railties (= 6.0.0.beta1)
railties (= 6.0.0.beta3)
sprockets-rails (>= 2.0.0)
rails-dom-testing (2.0.3)
activesupport (>= 4.2.0)
nokogiri (>= 1.6)
rails-html-sanitizer (1.0.4)
loofah (~> 2.2, >= 2.2.2)
railties (6.0.0.beta1)
actionpack (= 6.0.0.beta1)
activesupport (= 6.0.0.beta1)
railties (6.0.0.beta3)
actionpack (= 6.0.0.beta3)
activesupport (= 6.0.0.beta3)
method_source
rake (>= 0.8.7)
thor (>= 0.20.3, < 2.0)
@@ -223,22 +224,23 @@ GEM
websocket-driver (0.7.0)
websocket-extensions (>= 0.1.0)
websocket-extensions (0.1.3)
zeitwerk (1.4.2)

PLATFORMS
ruby

DEPENDENCIES
appraisal
aruba
bundler (~> 1.15)
bundler (~> 2.0.1)
coveralls
cucumber
komponent!
rails (~> 6.0.0.beta1)
rails (~> 6.0.0.beta3)
rake (>= 11.1)
rubocop
simplecov
webpacker

BUNDLED WITH
1.16.4
2.0.1
@@ -27,7 +27,7 @@ Gem::Specification.new do |spec|
end

spec.require_paths = ["lib"]
spec.required_ruby_version = '>= 2.3.0'
spec.required_ruby_version = '>= 2.5.0'

spec.add_dependency "actionview", ">= 5.0"
spec.add_dependency "activesupport", ">= 5.0"
@@ -9,7 +9,7 @@ class ComponentRenderer

def initialize(controller, view_flow = nil)
@context = controller.view_context.dup
@view_renderer = @context.view_renderer = @context.view_renderer.dup
@view_renderer = @context.view_renderer
@lookup_context = @view_renderer.lookup_context = @view_renderer.lookup_context.dup
@view_flow = view_flow
end

0 comments on commit 3aed172

Please sign in to comment.
You can’t perform that action at this time.