Permalink
Browse files

Reorganize gemspec

  • Loading branch information...
jdpace committed Dec 27, 2010
1 parent 405ee2a commit 26a12681e82aaefe97009741c2d276092a35b751
Showing with 24 additions and 69 deletions.
  1. +0 −1 Rakefile
  2. +0 −1 VERSION
  3. +1 −2 lib/pdfkit.rb
  4. +3 −0 lib/pdfkit/version.rb
  5. +20 −65 pdfkit.gemspec
View
@@ -2,7 +2,6 @@ require 'rubygems'
require 'rake'
require 'bundler'
Bundler::GemHelper.install_tasks
-Bundler.require(:development)
require 'rspec/core/rake_task'
RSpec::Core::RakeTask.new(:spec) do |spec|
View
@@ -1 +0,0 @@
-0.4.6
View
@@ -1,5 +1,4 @@
-require 'rubygems'
require 'pdfkit/source'
require 'pdfkit/pdfkit'
require 'pdfkit/middleware'
-require 'pdfkit/configuration'
+require 'pdfkit/configuration'
View
@@ -0,0 +1,3 @@
+class PDFKit
+ VERSION = "0.5.0"
+end
View
@@ -1,72 +1,27 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "pdfkit/version"
Gem::Specification.new do |s|
- s.name = %q{pdfkit}
- s.version = "0.4.6"
-
- s.required_rubygems_version = ">= 1.3.6"
- s.authors = ["jdpace"]
- s.date = %q{2010-12-27}
- s.description = %q{Uses wkhtmltopdf to create PDFs using HTML}
- s.email = %q{jared@codewordstudios.com}
- s.extra_rdoc_files = [
- "LICENSE",
- "README.md"
- ]
- s.platform = Gem::Platform::RUBY
- s.files = `git ls-files`.split("\n")
- s.executables = `git ls-files`.split("\n").map{|f| f =~ /^bin\/(.*)/ ? $1 : nil}.compact
- s.require_path = 'lib'
- s.homepage = %q{http://github.com/jdpace/PDFKit}
- s.post_install_message = %q{******************************************************************
-
-Install wkhtmltopdf:
-
-1. Install by hand (recomended):
-
- https://github.com/jdpace/PDFKit/wiki/Installing-WKHTMLTOPDF
-
-2. Try using the wkhtmltopdf-binary gem (mac + linux i386)
-
- gem install wkhtmltopdf-binary
-
-
-******************************************************************
-}
- s.rdoc_options = ["--charset=UTF-8"]
+ s.name = "pdfkit"
+ s.version = PDFKit::VERSION
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Jared Pace", "Relevance"]
+ s.email = ["jared@codewordstudios.com"]
+ s.homepage = "http://github.com/jdpace/PDFKit"
+ s.summary = "HTML+CSS -> PDF"
+ s.description = "Uses wkhtmltopdf to create PDFs using HTML"
+
+ s.rubyforge_project = "pdfkit"
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{HTML+CSS -> PDF}
- s.test_files = [
- "spec/middleware_spec.rb",
- "spec/pdfkit_spec.rb",
- "spec/source_spec.rb",
- "spec/spec_helper.rb"
- ]
-
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<rspec>, ["~> 2.0.0.beta.8"])
- s.add_development_dependency(%q<rspec-core>, ["~> 2.0.0.beta.8"])
- s.add_development_dependency(%q<mocha>, [">= 0"])
- s.add_development_dependency(%q<rack-test>, [">= 0"])
- else
- s.add_dependency(%q<rspec>, ["~> 2.0.0.beta.8"])
- s.add_dependency(%q<rspec-core>, ["~> 2.0.0.beta.8"])
- s.add_dependency(%q<mocha>, [">= 0"])
- s.add_dependency(%q<rack-test>, [">= 0"])
- end
- else
- s.add_dependency(%q<rspec>, ["~> 2.0.0.beta.8"])
- s.add_dependency(%q<rspec-core>, ["~> 2.0.0.beta.8"])
- s.add_dependency(%q<mocha>, [">= 0"])
- s.add_dependency(%q<rack-test>, [">= 0"])
- end
+ # Developmnet Dependencies
+ s.add_development_dependency(%q<rspec>, ["~> 2.2.0"])
+ s.add_development_dependency(%q<mocha>, [">= 0.9.10"])
+ s.add_development_dependency(%q<rack-test>, [">= 0.5.6"])
end

0 comments on commit 26a1268

Please sign in to comment.