New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Flip Y not always saved #103

Closed
omomthings opened this Issue Dec 22, 2015 · 6 comments

Comments

Projects
None yet
2 participants
@omomthings

omomthings commented Dec 22, 2015

The weird thing is that some sprites with the flipped y value is correctly saved, but not for all the entities. working with the 0.3.1-SNAPSHOT

@omomthings omomthings changed the title from Flip X/Y not always saved to Flip Y not always saved Dec 22, 2015

@omomthings

This comment has been minimized.

Show comment
Hide comment
@omomthings

omomthings Dec 22, 2015

Moreover, some elements with a flip Y set to false are saved with a true value, note that the entities with that problem are always the same!

omomthings commented Dec 22, 2015

Moreover, some elements with a flip Y set to false are saved with a true value, note that the entities with that problem are always the same!

@kotcrab

This comment has been minimized.

Show comment
Hide comment
@kotcrab

kotcrab Dec 22, 2015

Owner

It happens only with sprites right? If so, this should be fixed. This was actually fault of texture reloading not scene saving. Please confirm this fix works. Thanks!

Owner

kotcrab commented Dec 22, 2015

It happens only with sprites right? If so, this should be fixed. This was actually fault of texture reloading not scene saving. Please confirm this fix works. Thanks!

kotcrab added a commit that referenced this issue Dec 22, 2015

@kotcrab

This comment has been minimized.

Show comment
Hide comment
@kotcrab

kotcrab Dec 22, 2015

Owner

(new editor snapshot is still building)

Owner

kotcrab commented Dec 22, 2015

(new editor snapshot is still building)

@omomthings

This comment has been minimized.

Show comment
Hide comment
@omomthings

omomthings Dec 22, 2015

actually I only tried with sprites so I guess that you're right, I'll wait for the snapshot and i'll confirm if it's fixed!

omomthings commented Dec 22, 2015

actually I only tried with sprites so I guess that you're right, I'll wait for the snapshot and i'll confirm if it's fixed!

@kotcrab

This comment has been minimized.

Show comment
Hide comment
@kotcrab

kotcrab Dec 23, 2015

Owner

@omomthings any update on this one?

Owner

kotcrab commented Dec 23, 2015

@omomthings any update on this one?

@omomthings

This comment has been minimized.

Show comment
Hide comment
@omomthings

omomthings Dec 23, 2015

Tried last night and everything was good!

omomthings commented Dec 23, 2015

Tried last night and everything was good!

@omomthings omomthings closed this Dec 23, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment