Permalink
Browse files

Merge pull request #198 from cernekee/version-v1

Trivial fix for v4.3+ version check logic
  • Loading branch information...
koush committed Nov 16, 2013
2 parents b6b13f2 + 91ceab6 commit d5def0826e8f824cbd676f40fcfb5a8dfc03f7d3
Showing with 4 additions and 2 deletions.
  1. +1 −1 README.md
  2. +3 −1 Superuser/assets/update-binary
View
@@ -26,7 +26,7 @@ You'll need the "Widgets" dependency.
These repositories do not keep the actual projects in the top level directory.
This is because they contain tests, libs, and samples.
Make sure the SDK Platform for API 17 is installed, through the Android SDK Manager. Install NDK Revision 8e from [here](http://developer.android.com/tools/sdk/ndk/index.html).
Make sure the SDK Platform for API 19 is installed, through the Android SDK Manager. Install NDK Revision 9b from [here](http://developer.android.com/tools/sdk/ndk/index.html).
## Eclipse
@@ -62,8 +62,10 @@ MAJ=${VERSION%%.*}
MIN=${VERSION#*.}
MIN=${MIN//.*}
if [ "$MAJ" -ge 4 -a "$MIN" -ge 3 ]
if [ "${MAJ}${MIN}" -ge 43 ]
then
# on 4.3+, the daemon need not be setuid.
chmod 0755 /system/xbin/su
# check for rom su daemon before clobbering install-recovery.sh
if [ ! -f "/system/etc/.has_su_daemon" ]
then

0 comments on commit d5def08

Please sign in to comment.