Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Diff kitten broken in 0.16.0 for directories ? #2378

Closed
amanjitsk opened this issue Feb 19, 2020 · 2 comments
Closed

Diff kitten broken in 0.16.0 for directories ? #2378

amanjitsk opened this issue Feb 19, 2020 · 2 comments

Comments

@amanjitsk
Copy link

Hi,
Running kitty +kitten diff dir1 dir2 gives the following error in release 0.16.0
image
whereas the same command works as expected for version 0.15.1 . Is this a known bug or am I just missing a dependency ?
Thanks,
Amanjit

@kovidgoyal
Copy link
Owner

I cannot replicate and that traceback does not make much sense. Can you create a tarfile with minimal directories to comapre that generates the error?

@amanjitsk
Copy link
Author

Seems like the issue exists with .DS_store files on a mac, and some others like the attached .ropeproject directory. Put either one of these in a subdirectory of one of the two directories that will be diffed, and you should be able to replicate the error.
faulty.tar.gz

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

2 participants