changed activerecord/activesupport dependency version from <= 3.2.3 to ~> 3.2.3 #49

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
5 participants

omcnet commented Aug 24, 2012

No description provided.

omcnet commented Oct 5, 2012

Is there any test that is necessary to merge this change?
We have been using this db-charmer version with rails 3.2.8 for month without any issue.

ktham commented Oct 15, 2012

I'm wondering that too, I would like to use your gem but with rails 3.2.8 without having to make the change on dependency myself

Owner

kovyrin commented Oct 15, 2012

The issue with this and other pull requests is that they all break db-charmer test suite. Rails core team changed some internals of ActiveRecord in 3.2.4 and the tests break on all Rails versions since then. I simply do not have time to figure out what is wrong with those new versions but I do not want to deceive db-charmer users into believing that the gem is compatible with new Rails when it could very well be completely broken.

So, if you need to use newer version of rails, feel free to create a fork, change those 2 lines and use bundler :git to fetch your custom version until the official one with a proper fix will be available.

omcnet commented Oct 16, 2012

Hey,
thanks for your reply. I believe the tests are not part of the repository, or am I missing something?
Since we are using your gem in our company, we might find time to have a look on that issue.

yellow5 commented Oct 26, 2012

@omcnet have you had success in production with db-charmer after changing the dependency? i just started a task to upgrade some apps that use this gem to rails 3.2.8 and found out about the dependency limitation.

Owner

kovyrin commented Nov 13, 2012

DbCharmer 1.8.0 has been released with support for rails versions up to 3.2.9: https://rubygems.org/gems/db-charmer/versions/1.8.0.

kovyrin closed this Nov 13, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment