Permalink
Browse files

Removing seperate version file, updated history

  • Loading branch information...
1 parent debec12 commit 211a5e5cd9b11968f126b3b223bfcd6e66d90611 @quirkey quirkey committed Apr 22, 2010
Showing with 18 additions and 22 deletions.
  1. +3 −1 HISTORY
  2. +0 −1 Rakefile
  3. +5 −1 lib/oauth.rb
  4. +0 −1 lib/oauth/client/helper.rb
  5. +0 −3 lib/oauth/version.rb
  6. +10 −15 oauth.gemspec
View
@@ -1,6 +1,7 @@
-== 0.3.7
+== 0.4.0 2010-04-20
* Added computation of oauth_body_hash as per OAuth Request Body Hash 1.0
Draft 4 (Michael Reinsch)
+* Added the optional `oauth_session_handle` parameter for the Yahoo implementation (Will Bailey)
* Better marshalling implementation (Yoan Blanc)
* Added optional block to OAuth::Consumer.get_*_token (Neill Pearman)
* Exclude `oauth_callback` with :exclude_callback (Neill Pearman)
@@ -15,6 +16,7 @@
* Support for Typhoeus (Bill Kocik)
* Support for em-http (EventMachine) (Darcy Laycock)
* Support for curb (André Luis Leal Cardoso Junior)
+* New website (Aaron Quint)
== 0.3.6 2009-09-14
View
@@ -1,7 +1,6 @@
%w[rubygems rake rake/clean rake/testtask fileutils].each { |f| require f }
$LOAD_PATH << File.dirname(__FILE__) + '/lib'
require 'oauth'
-require 'oauth/version'
begin
require 'jeweler'
View
@@ -1,8 +1,12 @@
$LOAD_PATH << File.dirname(__FILE__) unless $LOAD_PATH.include?(File.dirname(__FILE__))
+module OAuth
+ VERSION = "0.4.0"
+end
+
require 'oauth/oauth'
require 'oauth/core_ext'
require 'oauth/client/helper'
require 'oauth/signature/hmac/sha1'
-require 'oauth/request_proxy/mock_request'
+require 'oauth/request_proxy/mock_request'
@@ -2,7 +2,6 @@
require 'oauth/consumer'
require 'oauth/helper'
require 'oauth/token'
-require 'oauth/version'
require 'oauth/signature/hmac/sha1'
module OAuth::Client
View
@@ -1,3 +0,0 @@
-module OAuth #:nodoc:
- VERSION = '0.3.7.pre1'
-end
View
@@ -5,24 +5,24 @@
Gem::Specification.new do |s|
s.name = %q{oauth}
- s.version = "0.3.7.pre1"
+ s.version = "0.4.0"
- s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Pelle Braendgaard", "Blaine Cook", "Larry Halff", "Jesse Clark", "Jon Crosby", "Seth Fitzsimmons", "Matt Sanford", "Aaron Quint"]
- s.date = %q{2010-03-09}
+ s.date = %q{2010-04-21}
s.default_executable = %q{oauth}
s.description = %q{OAuth Core Ruby implementation}
s.email = %q{oauth-ruby@googlegroups.com}
s.executables = ["oauth"]
s.extra_rdoc_files = [
- "README.rdoc",
+ "LICENSE",
+ "README.rdoc",
"TODO"
]
s.files = [
".gitignore",
- "History.txt",
- "License.txt",
- "Manifest.txt",
+ "HISTORY",
+ "LICENSE",
"README.rdoc",
"Rakefile",
"TODO",
@@ -73,12 +73,7 @@ Gem::Specification.new do |s|
"lib/oauth/tokens/request_token.rb",
"lib/oauth/tokens/server_token.rb",
"lib/oauth/tokens/token.rb",
- "lib/oauth/version.rb",
"oauth.gemspec",
- "script/destroy",
- "script/generate",
- "script/txt2html",
- "setup.rb",
"tasks/deployment.rake",
"tasks/environment.rake",
"tasks/website.rake",
@@ -156,22 +151,22 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<actionpack>, [">= 2.2.0", "< 2.3"])
+ s.add_development_dependency(%q<actionpack>, [">= 2.2.0", "< 2.3.0"])
s.add_development_dependency(%q<rack>, [">= 1.0.0"])
s.add_development_dependency(%q<mocha>, [">= 0.9.8"])
s.add_development_dependency(%q<typhoeus>, [">= 0.1.13"])
s.add_development_dependency(%q<em-http-request>, [">= 0"])
s.add_development_dependency(%q<curb>, [">= 0.6.6.0"])
else
- s.add_dependency(%q<actionpack>, [">= 2.2.0", "< 2.3"])
+ s.add_dependency(%q<actionpack>, [">= 2.2.0", "< 2.3.0"])
s.add_dependency(%q<rack>, [">= 1.0.0"])
s.add_dependency(%q<mocha>, [">= 0.9.8"])
s.add_dependency(%q<typhoeus>, [">= 0.1.13"])
s.add_dependency(%q<em-http-request>, [">= 0"])
s.add_dependency(%q<curb>, [">= 0.6.6.0"])
end
else
- s.add_dependency(%q<actionpack>, [">= 2.2.0", "< 2.3"])
+ s.add_dependency(%q<actionpack>, [">= 2.2.0", "< 2.3.0"])
s.add_dependency(%q<rack>, [">= 1.0.0"])
s.add_dependency(%q<mocha>, [">= 0.9.8"])
s.add_dependency(%q<typhoeus>, [">= 0.1.13"])

0 comments on commit 211a5e5

Please sign in to comment.