Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Lightweight threads for Java, with message passing, nio, http and scheduling support.
Java Ragel in Ruby Host Objective-J Erlang Scala Haskell Other
Branch: asm-4.0

This branch is 57 commits ahead, 36 commits behind kilim:master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
.settings
bench
docs
examples/kilim/examples
libs
src
.classpath
.gitignore
.project
LICENSE
Makefile
README.md
build.xml
pom.xml

README.md

Kilim

Lightweight local/distributed concurrency for Java by message passing

Version v0.7 -- Copyright (c) 2006 Sriram Srinivasan kilim@malhar.net

Overview

This software is released under an MIT-style licesne (please see the License file). Please see docs/manual.txt and docs/kilim_ecoop08.pdf for a brief introduction.

Please use GitHub to report bugs (or better yet submit pull requests). Social Coding, FTW!

Building

Use Maven to build, test and install Kilim.

Compile

To compile the source into a jar file simply:

``bash mvn compile


### Test

To exercise the test suite simply:

```bash
mvn test

Examples

To run an example:

java -cp ./classes:$CLASSPATH kilim.examples.Chain 10

Dependencies

ASM 4.0

This software depends on the ASM bytecode library (v 4.0).

If you don't have ASM version 4.0 installed in your ~/.m2 directory you'll want to install it. There is a copy in the libs directory, to install it simply do the following:

mvn install:install-file -Dfile=libs/asm-debug-all-4.0.jar -DgroupId=asm -DartifactId=asm-all -Dversion=4.0 -Dpackaging=jar

After which you'll see Maven do some magic resulting in the following:

/home/you/.m2/repository/asm/asm-all/4.0/asm-all-4.0.jar
/home/you/.m2/repository/asm/asm-all/4.0/asm-all-4.0.jar.lastUpdated
/home/you/.m2/repository/asm/asm-all/4.0/asm-all-4.0.pom
/home/you/.m2/repository/asm/asm-all/4.0/asm-all-4.0.pom.lastUpdated

Java 7 (1.7.x)

This library has been ported to Java 7. It's now "Write once, run on JDK7 only."

Something went wrong with that request. Please try again.