Skip to content
Browse files

Specify SDKs based on DEVELOPER_SDK_DIR, not hardcoded /Developer/SDK…

…s. For people who have installed Xcode in other locations (only possible fairly recently, after Xcode 3.2.4? but more common now with Xcode 4)
  • Loading branch information...
1 parent 410958c commit 862fa954e455adc347c2df86580f25bc1c94bece @krevis committed Mar 16, 2011
Showing with 3 additions and 3 deletions.
  1. +2 −2 Configurations/Snoize-IBPlugin-Global.xcconfig
  2. +1 −1 Configurations/Snoize-Project-Global.xcconfig
View
4 Configurations/Snoize-IBPlugin-Global.xcconfig
@@ -1,9 +1,9 @@
// The new IB plugin framework only supports 10.5, so we must override the settings in Snoize-Project-Global.xcconfig to use the 10.5 SDK and target, for both Intel and PPC.
-SDKROOT = /Developer/SDKs/MacOSX10.5.sdk
+SDKROOT = ${DEVELOPER_SDK_DIR}/MacOSX10.5.sdk
MACOSX_DEPLOYMENT_TARGET = 10.5
-SDKROOT_ppc = /Developer/SDKs/MacOSX10.5.sdk
+SDKROOT_ppc = ${DEVELOPER_SDK_DIR}/MacOSX10.5.sdk
MACOSX_DEPLOYMENT_TARGET_ppc = 10.5
GCC_VERSION_ppc = 4.0
View
2 Configurations/Snoize-Project-Global.xcconfig
@@ -1,5 +1,5 @@
// Typically build against 10.4
-SDKROOT = /Developer/SDKs/MacOSX10.4u.sdk
+SDKROOT = ${DEVELOPER_SDK_DIR}/MacOSX10.4u.sdk
// meaning: maximum API usage allowed is 10.4
MACOSX_DEPLOYMENT_TARGET = 10.4
// meaning: minimum machine we'll attempt to run on is 10.4

0 comments on commit 862fa95

Please sign in to comment.
Something went wrong with that request. Please try again.