New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Request for ARM support #22

Open
bartbutenaers opened this Issue Dec 19, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@bartbutenaers
Copy link

bartbutenaers commented Dec 19, 2018

Hi Kristoffer (@kribblo),

When I try following code on a Raspberry Pi 3 Model B (running Raspbian):

    const ffmpeg = require('@ffmpeg-installer/ffmpeg');
    console.log(ffmpeg.path, ffmpeg.version);

Then the result is "Unsupported platform/architecture: linux-arm".

Do you have plans to support ARM processors?
Perhaps following information allows you to determine whether it is possible or not:

  • Seems that Debian supports 3 ports of ARM hardware (armhf / armel / arm64), where both armhf and armel are 32-bit.
  • I found two ways to determine the hardware: see 1 and 2.
  • And here there are binaries available for armhf/armel/arm64.

Thanks for your time !!
Bart

@kribblo

This comment has been minimized.

Copy link
Owner

kribblo commented Dec 19, 2018

No plans as such, but not opposed to it either! You have already done some of the research I see. If you like to do a pull request it would be even faster, otherwise I will look into it

@bartbutenaers

This comment has been minimized.

Copy link
Author

bartbutenaers commented Dec 19, 2018

Wow, that was fast ;-)
Glad to hear that you are not against it ...
Just saw on the link where you fetch your binaries, that armhf/rmel/arm64 binaries are also available. So we can already forget about my link, to keep your code more consistent!
If you would have some time left to implement it, that would be highly appreciated! Otherwise I will try to create a pull request. But that might take a bit longer, since I'm not experienced with debugging such installer code ...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment