Skip to content
This is a work in progress
Ruby JavaScript
Find file
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
app Split one liner up in to two methods
config Allow the admin route/URL namespace to be changed
db Fix: Document manual sorting is broken
lib Bump version to 0.0.7.pre
script
test
.gitignore Gemfile.lock should not be versioned
.rvmrc Update simple_form and kaminari dependencies as they no longer need t…
Gemfile Update simple_form and kaminari dependencies as they no longer need t…
MIT-LICENSE Initial concept in a Rails 3.1 Engine
README.md Update simple_form and kaminari dependencies as they no longer need t…
Rakefile Initial concept in a Rails 3.1 Engine
qwerty.gemspec

README.md

Qwerty

Install

gem 'qwerty'

For now we also need to add an additional dependancy to your Gemfile, since the qwerty gemspec can not depend on git repositories only released versions.

gem 'kaminari', '0.13.0'
rake qwerty_engine:install:migrations
rake db:migrate
rails g qwerty:install

Developer Notes

Vim users: To allow rails.vim to detect this is as a Rails project "touch config/environment.rb", which has already been added to .gitignore.

Release Policy

Create release branch from next Bump version in Qwerty module: http://semver.org/ Document release as required Merge release branch in to master and next Tag master using with 'v' prefix e.g v0.0.1 Build and push gem to Rubyforge: http://yehudakatz.com/2010/04/02/using-gemspecs-as-intended/

This project rocks and uses MIT-LICENSE.

Something went wrong with that request. Please try again.