Help for installation #1

Open
eric-smartlove opened this Issue Sep 13, 2012 · 2 comments

Comments

Projects
None yet
2 participants

I wanted to use Bootstrap-Image-Gallery but I appreciate using a gem for an easier maintenance. So thank you very much for your work.

At the beginning I had some problems on the installation of boostrap-addons-rails and I would like to share the solutions so others can learn from my mistakes.

In addition to what is written in the documentation, I had to add

<script src="http://blueimp.github.com/JavaScript-Load-Image/load-image.min.js"></script>

in my html file.
Maybe this file could be included in this gem?

Furthermore, to include the css, instead of

*= require bootstrap/image-gallery

I had to use

@import "bootstrap/image-gallery";

probably because I use the gem bootstrap-sass and I use @import instead of rails require as they recommend.
Maybe the documentation of bootstrap-addons-rails can deal with that?

Owner

kristianmandrup commented Sep 14, 2012

I've now updated the README docs. Thanks!

Very fast update !

I now use version 0.1.1 and I can remove the html script balise.

However you should change :

//= require bootstrap/load-image-min

for

//= require bootstrap/load-image.min

in the docs.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment