Skip to content
Newer
Older
100644 25 lines (19 sloc) 945 Bytes
7de4135 @beerlington Regenerate gemspec for version 0.9.0
beerlington authored Jun 7, 2011
1 # -*- encoding: utf-8 -*-
d872ae7 @beerlington Changing from Jeweler to Bundler for gem management
beerlington authored Jun 10, 2012
2 require File.expand_path('../lib/classy_enum/version', __FILE__)
7de4135 @beerlington Regenerate gemspec for version 0.9.0
beerlington authored Jun 7, 2011
3
d872ae7 @beerlington Changing from Jeweler to Bundler for gem management
beerlington authored Jun 10, 2012
4 Gem::Specification.new do |gem|
5 gem.authors = ["Peter Brown"]
6 gem.email = ["github@lette.us"]
7 gem.description = "A utility that adds class based enum functionality to ActiveRecord attributes"
8 gem.summary = "A class based enumerator utility for Ruby on Rails"
9 gem.homepage = "http://github.com/beerlington/classy_enum"
7de4135 @beerlington Regenerate gemspec for version 0.9.0
beerlington authored Jun 7, 2011
10
d872ae7 @beerlington Changing from Jeweler to Bundler for gem management
beerlington authored Jun 10, 2012
11 gem.files = `git ls-files`.split($\)
12 gem.test_files = gem.files.grep(%r{^(test|spec|features)/})
13 gem.name = "classy_enum"
14 gem.require_paths = ["lib"]
15 gem.version = ClassyEnum::VERSION
7de4135 @beerlington Regenerate gemspec for version 0.9.0
beerlington authored Jun 7, 2011
16
d872ae7 @beerlington Changing from Jeweler to Bundler for gem management
beerlington authored Jun 10, 2012
17 gem.add_dependency('rails', '>= 3.0')
7de4135 @beerlington Regenerate gemspec for version 0.9.0
beerlington authored Jun 7, 2011
18
f8e1d0a @beerlington Updating spec dependencies
beerlington authored Jul 13, 2012
19 gem.add_development_dependency('rspec-rails', '~> 2.11.0')
d872ae7 @beerlington Changing from Jeweler to Bundler for gem management
beerlington authored Jun 10, 2012
20 gem.add_development_dependency('sqlite3', '~> 1.3.6')
21 gem.add_development_dependency('json', '~> 1.6.5')
7de4135 @beerlington Regenerate gemspec for version 0.9.0
beerlington authored Jun 7, 2011
22
aad8029 @kristianmandrup added macros with spec, README update and a macro enum template for g…
authored Aug 4, 2012
23 gem.add_development_dependency("RubyInline", "~> 3.11.3")
d872ae7 @beerlington Changing from Jeweler to Bundler for gem management
beerlington authored Jun 10, 2012
24 end
Something went wrong with that request. Please try again.