Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Commits on Jul 23, 2012
  1. @beerlington
  2. @beerlington
  3. @beerlington
Commits on Jul 20, 2012
  1. @beerlington
  2. @beerlington

    Bumping to v2.3.0

    beerlington authored
  3. @beerlington

    Deprecating ClassyEnum::Base#name

    beerlington authored
    Method name is too ambiguous and says nothing about what it actually did
Commits on Jul 15, 2012
  1. @beerlington

    Deprecating non-namespaced class names (v2.2.0)

    beerlington authored
    Non-namespaced class names will be unsupported in 3.0
  2. @beerlington
Commits on Jul 13, 2012
  1. @beerlington
  2. @beerlington

    Bumping to v 2.1.0

    beerlington authored
  3. @beerlington
Commits on Jun 14, 2012
  1. @beerlington
Commits on Jun 13, 2012
  1. @beerlington

    Update README to better explain owner reference

    beerlington authored
    The owner reference is available by default as `owner`, but the readme
    did not make this clear.
Commits on Jun 10, 2012
  1. @beerlington
  2. @beerlington
  3. @beerlington
Commits on Apr 24, 2012
  1. @beerlington
  2. @beerlington
  3. @beerlington
  4. @beerlington

    Version bump to 2.0.3

    beerlington authored
  5. @beerlington

    Fixing readme formatting

    beerlington authored
  6. @beerlington

    Fixing issue with validates_uniqueness_of

    beerlington authored
    Addresses issue #8 without relying on :suffix option
Commits on Apr 22, 2012
  1. @beerlington
  2. @beerlington

    Version bump to 2.0.2

    beerlington authored
  3. @beerlington
  4. @beerlington
  5. @beerlington

    Version bump to 2.0.1

    beerlington authored
  6. @beerlington
  7. @beerlington
  8. @beerlington
  9. @beerlington

    Version bump to 2.0.0

    beerlington authored
  10. @beerlington

    Removing hacky code Rails 3.0 code

    beerlington authored
    There is a known issue with Rails 3.x and above when using
    validates_uniqueness_of and an enum scope. This issue was patched when
    providing support for 3.0 but then broke again in 3.1 and 3.2. It
    doesn't make sense to have a hack that only works in an older version of
    Rails.
  11. @beerlington
  12. @beerlington
  13. @beerlington
Something went wrong with that request. Please try again.