Permalink
Browse files

changed gem name

  • Loading branch information...
1 parent d7f6f9e commit de77a9a4331478b5560a38d03a0199c9b274565a @kristianmandrup committed Aug 30, 2012
View
@@ -2,6 +2,7 @@ source "http://rubygems.org"
gem 'rails', '>= 3.1'
gem 'compass', '>= 0.11'
+gem 'sass', '>= 3.0'
group :development do
gem "rspec", ">= 2.8.0"
View
@@ -114,4 +114,5 @@ DEPENDENCIES
rails (>= 3.1)
rdoc (>= 3.12)
rspec (>= 2.8.0)
+ sass (>= 3.0)
simplecov (>= 0.5)
View
@@ -1,4 +1,4 @@
-# Font Awesome for Rails asset pipeline
+# Font Awesome for Rails asset pipeline with SASS and SCSS
The iconic font designed for use with _Twitter Bootstrap_
@@ -7,7 +7,7 @@ The full suite of pictographic icons, examples, and documentation can be found a
## Install
-`gem 'font-awesome-rails'`
+`gem 'font_awesome-sass-rails'`
Then `bundle` it!
View
@@ -1,4 +1,5 @@
-# encoding: utf-8
+# -*- encoding: utf-8 -*-
+require File.expand_path('../lib/font_awesome-sass/version', __FILE__)
require 'rubygems'
require 'bundler'
@@ -14,7 +15,7 @@ require 'rake'
require 'jeweler'
Jeweler::Tasks.new do |gem|
# gem is a Gem::Specification... see http://docs.rubygems.org/read/chapter/20 for more options
- gem.name = "font-awesome-rails"
+ gem.name = "font_awesome-sass-rails"
gem.homepage = "http://github.com/kristianmandrup/font-awesome-rails"
gem.license = "MIT"
gem.summary = %Q{Font Awesome ready for use with Rails asset pipeline}
@@ -2,10 +2,11 @@
# DO NOT EDIT THIS FILE DIRECTLY
# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+require File.expand_path('../lib/font_awesome-sass/version', __FILE__)
Gem::Specification.new do |s|
- s.name = "font-awesome-rails"
- s.version = "2.0.0"
+ s.name = "font_awesome-sass-rails"
+ s.version = FontAwesomeSass::Rails::VERSION
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Kristian Mandrup"]
@@ -26,9 +27,9 @@ Gem::Specification.new do |s|
"README.md",
"Rakefile",
"VERSION",
- "font-awesome-rails.gemspec",
- "lib/font-awesome-rails.rb",
- "lib/font-awesome/engine.rb",
+ "lib/font_awesome-sass-rails.rb",
+ "lib/font_awesome-sass/engine.rb",
+ "lib/font_awesome-sass/version.rb",
"spec/spec_helper.rb",
"vendor/assets/fonts/FontAwesome.ttf",
"vendor/assets/fonts/fontawesome-webfont.eot",
@@ -53,6 +54,7 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<rails>, [">= 3.1"])
s.add_runtime_dependency(%q<compass>, [">= 0.11"])
+ s.add_runtime_dependency(%q<sass>, [">= 3.0"])
s.add_development_dependency(%q<rspec>, [">= 2.8.0"])
s.add_development_dependency(%q<rdoc>, [">= 3.12"])
s.add_development_dependency(%q<bundler>, [">= 1.0.0"])
@@ -61,6 +63,7 @@ Gem::Specification.new do |s|
else
s.add_dependency(%q<rails>, [">= 3.1"])
s.add_dependency(%q<compass>, [">= 0.11"])
+ s.add_dependency(%q<sass>, [">= 3.0"])
s.add_dependency(%q<rspec>, [">= 2.8.0"])
s.add_dependency(%q<rdoc>, [">= 3.12"])
s.add_dependency(%q<bundler>, [">= 1.0.0"])
@@ -70,6 +73,7 @@ Gem::Specification.new do |s|
else
s.add_dependency(%q<rails>, [">= 3.1"])
s.add_dependency(%q<compass>, [">= 0.11"])
+ s.add_dependency(%q<sass>, [">= 3.0"])
s.add_dependency(%q<rspec>, [">= 2.8.0"])
s.add_dependency(%q<rdoc>, [">= 3.12"])
s.add_dependency(%q<bundler>, [">= 1.0.0"])
@@ -1,2 +0,0 @@
-require 'font-awesome/engine' if defined?(::Rails::Engine)
-
@@ -0,0 +1,3 @@
+require 'font_awesome-sass/version'
+require 'font_awesome-sass/engine' if defined?(::Rails::Engine)
+
@@ -1,4 +1,4 @@
-module FontAwesome
+module FontAwesomeSass
module Rails
class Engine < ::Rails::Engine
end
@@ -0,0 +1,5 @@
+module FontAwesomeSass
+ module Rails
+ VERSION = "2.0.0"
+ end
+end

0 comments on commit de77a9a

Please sign in to comment.