Permalink
Browse files

updated dependencies and bumped version

  • Loading branch information...
1 parent 692b245 commit ebfa3e69e06c2bf8d652b6319faa73db3d201116 @kristianmandrup committed Jun 4, 2011
Showing with 22 additions and 22 deletions.
  1. +9 −9 Gemfile
  2. +5 −7 README.markdown
  3. +2 −0 Rakefile
  4. +1 −1 lib/mm-devise/version.rb
  5. +5 −5 mm-devise.gemspec
View
@@ -7,19 +7,19 @@ group :test do
end
group :default do
- gem "rails", "~> 3.0.7"
+ gem "rails", "~> 3.0.7"
gem "webrat", "~> 0.7.2"
- gem 'mongo_mapper', '0.9.0'
- gem 'sugar-high', '~> 0.3.4'
- gem 'devise', '>= 1.1.1'
- gem 'rails3-generators', '>= 0.13.0'
- gem 'bson_ext', '>= 1.0.9'
+ gem 'mongo_mapper', '~> 0.9.0'
+ gem 'sugar-high', '~> 0.4.3'
+ gem 'devise', '>= 1.2.0'
+ # gem 'rails3-generators', '>= 0.14.0'
+ gem 'bson_ext', '>= 1.2.0'
- gem 'rake', '0.8.7'
+ gem 'rake', '>= 0.8.7'
gem "orm_adapter"
- gem "oa-oauth", '~> 0.2.0', :require => "omniauth/oauth"
- gem "oa-openid", '~> 0.2.0', :require => "omniauth/openid"
+ gem "oa-oauth", '~> 0.2.0', :require => "omniauth/oauth"
+ gem "oa-openid", '~> 0.2.0', :require => "omniauth/openid"
platforms :mri_18 do
gem "SystemTimer"
View
@@ -25,11 +25,11 @@ ActiveModel support will likely be part of *MongoMapper 1.0* (as mentioned by jn
Add *devise*, *mm-devise* and *MongoMapper* gems to your Gemfile (your Rails app Gemfile). The following gems are required
-<pre> gem 'mongo_mapper', '>= 0.8.2'
+<pre> gem 'mongo_mapper', '>= 0.9.0'
gem 'jnunemaker-validatable', '>= 1.8.4'
- gem 'bson_ext', '>= 1.0.9'
- gem 'devise', '>= 1.1.1'
- gem 'mm-devise', '>= 1.1.8'
+ gem 'bson_ext', '>= 1.3'
+ gem 'devise', '>= 1.2'
+ gem 'mm-devise', '>= 1.2'
# gem 'rails3-generators', '>= 0.14.0' # optional</pre>
You can install [rails3-generators](http://github.com/indirect/rails3-generators) which includes a *mongo_mapper* Model generator
@@ -77,9 +77,6 @@ cd mm-devise
bundle install
rake test</pre>
-When you run <code>rake test</code>, you will (as of Aug 6, 2010) still get a few errors and failures.
-This is NOT due to any errors in <code>mm-devise</code> but rather due to a few "issues" with a few of the devise tests themselves IMO.
-
## Gem install
<pre>$ rake install</pre>
@@ -104,6 +101,7 @@ This is NOT due to any errors in <code>mm-devise</code> but rather due to a few
## Contributors
+*bmarini* - Updated to support MongoMapper 0.9 (June 2011)
*bhbryant* - Fixed some issues and updated gem (Jan 2011)
*Jared Morgan* - Created the dm-devise gem which was used as a template for the development of this gem.
Also made suggestions for a few critical fixes and improvements in the code. Thanks :)
View
@@ -1,6 +1,8 @@
# encoding: UTF-8
require 'rake'
+include Rake::DSL if defined?(Rake::DSL)
+
require 'bundler'
Bundler::GemHelper.install_tasks
@@ -1,5 +1,5 @@
module MongoMapper
module Devise
- VERSION = '1.1.10'.freeze
+ VERSION = '1.2' #.freeze
end
end
View
@@ -5,19 +5,19 @@ require "mm-devise/version"
Gem::Specification.new do |s|
s.name = "mm-devise"
s.version = MongoMapper::Devise::VERSION
- s.date = "2011-01-11"
+ s.date = "2011-06-01"
s.summary = %Q{Support for using MongoMapper ORM with devise}
s.description = %Q{dm-devise adds MongoMapper support to devise (http://github.com/plataformatec/devise) for authentication support for Rails}
- s.email = "jmorgan@morgancreative.net"
+ s.email = "kmandrup@gmail.com"
s.homepage = "http://github.com/kristianmandrup/mm-devise"
s.authors = ["Kristian Mandrup"]
s.files = Dir.glob("lib/**/*") + %w(Changelog.txt mm-devise.gemspec Gemfile LICENSE Rakefile README.markdown)
s.test_files = Dir.glob("test/**/*")
s.add_dependency 'mongo_mapper', '>= 0.9.0'
- s.add_dependency 'devise', '>= 1.1.1'
- s.add_dependency 'rails3-generators', '>= 0.13.0'
- s.add_dependency 'sugar-high', '~> 0.3.0'
+ s.add_dependency 'devise', '>= 1.2'
+ # s.add_dependency 'rails3-generators', '>= 0.14.0'
+ s.add_dependency 'sugar-high', '~> 0.4.3'
s.add_dependency "SystemTimer", "~> 1.2" if RUBY_VERSION < "1.9"
end

0 comments on commit ebfa3e6

Please sign in to comment.