Permalink
Browse files

mongoid 3.1+ support

  • Loading branch information...
1 parent dee1fcc commit fb9b392c55776145bd7fe175e5318a044e6af28a @kristianmandrup committed Feb 27, 2013
Showing with 15 additions and 18 deletions.
  1. +7 −8 Gemfile
  2. +6 −8 Gemfile.lock
  3. +1 −1 README.md
  4. +1 −1 VERSION
View
15 Gemfile
@@ -1,11 +1,11 @@
-source :rubygems
+source 'https://rubygems.org'
gem 'money'
-gem 'mongoid', "~> 3.0"
-gem 'origin'
-gem 'moped'
+gem 'mongoid', ">= 2.4"
+gem 'origin', '>= 1'
+gem 'moped', '>= 1'
gem 'origin-selectable_ext'
-gem 'sugar-high', '~> 0.7.0'
+gem 'sugar-high', '>= 0.7.2'
# gem 'mongoid', "~> 2.4"
# gem 'bson'
@@ -19,7 +19,6 @@ group :development do
gem "simplecov",">= 0.5"
end
-group :test do
- gem 'moped'
- gem 'bson_ext'
+group :test do
+ gem 'bson'
end
View
@@ -1,5 +1,5 @@
GEM
- remote: http://rubygems.org/
+ remote: https://rubygems.org/
specs:
activemodel (3.2.8)
activesupport (= 3.2.8)
@@ -8,8 +8,6 @@ GEM
i18n (~> 0.6)
multi_json (~> 1.0)
bson (1.7.0)
- bson_ext (1.7.0)
- bson (~> 1.7.0)
builder (3.0.3)
diff-lcs (1.1.3)
git (1.2.5)
@@ -55,15 +53,15 @@ PLATFORMS
ruby
DEPENDENCIES
- bson_ext
+ bson
bundler (>= 1.1.0)
jeweler (>= 1.8.4)
money
- mongoid (~> 3.0)
- moped
- origin
+ mongoid (>= 2.4)
+ moped (>= 1)
+ origin (>= 1)
origin-selectable_ext
rdoc (>= 3.12)
rspec (>= 2.10)
simplecov (>= 0.5)
- sugar-high (~> 0.7.0)
+ sugar-high (>= 0.7.2)
View
@@ -1,6 +1,6 @@
# Money for mongoid
-Use the [money](https://github.com/RubyMoney/money) gem with Mongoid 2.x and 3.x.
+Use the [money](https://github.com/RubyMoney/money) gem with Mongoid 2.4+, 3 (and 4).
## Install
View
@@ -1 +1 @@
-0.2.1
+0.2.2

0 comments on commit fb9b392

Please sign in to comment.