Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

woops fix some build issues

  • Loading branch information...
commit aa05e7ec3795b72cd9ff7a5ba900c63c4c71f5a3 1 parent 3ce096f
@ryanong ryanong authored
Showing with 21 additions and 1 deletion.
  1. +16 −0 Rakefile
  2. +0 −1  lib/mongoid_spacial.rb
  3. +5 −0 mongoid_spacial.gemspec
View
16 Rakefile
@@ -1,2 +1,18 @@
#!/usr/bin/env rake
require "bundler/gem_tasks"
+
+require 'rspec/core'
+require 'rspec/core/rake_task'
+RSpec::Core::RakeTask.new(:spec) do |spec|
+ spec.pattern = FileList['spec/**/*_spec.rb']
+end
+
+RSpec::Core::RakeTask.new(:rcov) do |spec|
+ spec.pattern = 'spec/**/*_spec.rb'
+ spec.rcov = true
+end
+
+task :default => :spec
+
+require 'yard'
+
View
1  lib/mongoid_spacial.rb
@@ -4,7 +4,6 @@
require 'mongoid_spacial/contexts/mongo'
require 'mongoid_spacial/criteria'
require 'mongoid_spacial/criterion'
-require 'mongoid_spacial/extentions/hash/criteria_helpers'
require 'mongoid_spacial/extentions/symbol/inflections'
require 'mongoid_spacial/field_option'
require 'mongoid_spacial/finders'
View
5 mongoid_spacial.gemspec
@@ -19,4 +19,9 @@ Gem::Specification.new do |gem|
gem.add_dependency('activesupport', ["~> 3.0"])
gem.add_development_dependency('yard', ["~>0.6.0"])
gem.add_development_dependency('rspec', ['~>2.3'])
+ gem.add_development_dependency('rcov', ['>= 0'])
+ gem.add_development_dependency('mocha', ['>= 0'])
+ gem.add_development_dependency('will_paginate', ['>= 0'])
+ gem.add_development_dependency('kaminari', ['>= 0'])
+
end
Please sign in to comment.
Something went wrong with that request. Please try again.