Browse files

more flexible dependencies for rails and mongoid 4 support

  • Loading branch information...
1 parent c196b75 commit 27240158e750e5656989a42f9155fd3a5837fd3a @kristianmandrup committed Feb 26, 2013
Showing with 5 additions and 5 deletions.
  1. +1 −1 Gemfile
  2. +0 −1 README.md
  3. +4 −3 mongoid_geospatial.gemspec
View
2 Gemfile
@@ -1,7 +1,7 @@
source 'http://rubygems.org'
gemspec # Specify gem's dependencies in mongoid_geospatial.gemspec
-gem 'mongoid', '~> 3.0'
+gem 'mongoid', '>= 3.0'
group :development do
gem 'rgeo'
View
1 README.md
@@ -14,7 +14,6 @@ There are no plans to support MongoDB < 2.0
There are no plans to support Mongoid <= 2.0
-
Quick Start
-----------
View
7 mongoid_geospatial.gemspec
@@ -16,9 +16,10 @@ Gem::Specification.new do |gem|
gem.version = Mongoid::Geospatial::VERSION
gem.add_dependency('mongoid', ['>= 3.0.0'])
- gem.add_dependency('activesupport', ["~> 3.2"])
- gem.add_development_dependency('yard', ["~>0.6.0"])
- gem.add_development_dependency('rspec', ['~>2.11'])
+ gem.add_dependency('activesupport', [">= 3.2"])
+
+ gem.add_development_dependency('yard', [">=0.6.0"])
+ gem.add_development_dependency('rspec', ['>=2.11'])
gem.add_development_dependency('mocha', ['>= 0'])
gem.add_development_dependency('will_paginate', ['>= 0'])
gem.add_development_dependency('kaminari', ['>= 0'])

0 comments on commit 2724015

Please sign in to comment.