Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 75 lines (69 sloc) 2.497 kb
066e400 Kristian Mandrup gemspec
authored
1 # Generated by jeweler
2 # DO NOT EDIT THIS FILE DIRECTLY
3 # Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
4 # -*- encoding: utf-8 -*-
5
6 Gem::Specification.new do |s|
7 s.name = "params_extractor"
f37f325 Kristian Mandrup Regenerate gemspec for version 0.2.1
authored
8 s.version = "0.2.1"
066e400 Kristian Mandrup gemspec
authored
9
10 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
11 s.authors = ["Kristian Mandrup"]
f37f325 Kristian Mandrup Regenerate gemspec for version 0.2.1
authored
12 s.date = "2012-05-08"
c898fed Kristian Mandrup all specs pass
authored
13 s.description = "Encode and encrypt prams and leter unencryt and decode them - useful when sending invites with tokens"
066e400 Kristian Mandrup gemspec
authored
14 s.email = "kmandrup@gmail.com"
15 s.extra_rdoc_files = [
16 "LICENSE.txt",
17 "README.md"
18 ]
19 s.files = [
20 ".document",
21 ".rspec",
22 "Gemfile",
23 "Gemfile.lock",
24 "LICENSE.txt",
25 "README.md",
26 "Rakefile",
27 "VERSION",
5d01a8c Kristian Mandrup Regenerate gemspec for version 0.2.0
authored
28 "lib/params/base.rb",
55606d2 Kristian Mandrup Regenerate gemspec for version 0.1.1
authored
29 "lib/params/crypter.rb",
30 "lib/params/decoder.rb",
31 "lib/params/encoder.rb",
066e400 Kristian Mandrup gemspec
authored
32 "lib/params_extractor.rb",
c898fed Kristian Mandrup all specs pass
authored
33 "params_extractor.gemspec",
5d01a8c Kristian Mandrup Regenerate gemspec for version 0.2.0
authored
34 "spec/decoder_ex.rb",
35 "spec/encoder_ex.rb",
36 "spec/params_extractor/crypter_spec.rb",
37 "spec/params_extractor/decoder_spec.rb",
38 "spec/params_extractor/encoder_spec.rb",
066e400 Kristian Mandrup gemspec
authored
39 "spec/spec_helper.rb"
40 ]
41 s.homepage = "http://github.com/kristianmandrup/params_extractor"
42 s.licenses = ["MIT"]
43 s.require_paths = ["lib"]
5d01a8c Kristian Mandrup Regenerate gemspec for version 0.2.0
authored
44 s.rubygems_version = "1.8.24"
c898fed Kristian Mandrup all specs pass
authored
45 s.summary = "Package and unpackage URL params as encrypted tokens"
066e400 Kristian Mandrup gemspec
authored
46
47 if s.respond_to? :specification_version then
48 s.specification_version = 3
49
50 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
51 s.add_runtime_dependency(%q<gibberish>, [">= 0"])
52 s.add_development_dependency(%q<rspec>, [">= 2.8.0"])
53 s.add_development_dependency(%q<rdoc>, [">= 3.12"])
54 s.add_development_dependency(%q<bundler>, [">= 1.1.0"])
55 s.add_development_dependency(%q<jeweler>, [">= 1.8.3"])
56 s.add_development_dependency(%q<simplecov>, [">= 0.5"])
57 else
58 s.add_dependency(%q<gibberish>, [">= 0"])
59 s.add_dependency(%q<rspec>, [">= 2.8.0"])
60 s.add_dependency(%q<rdoc>, [">= 3.12"])
61 s.add_dependency(%q<bundler>, [">= 1.1.0"])
62 s.add_dependency(%q<jeweler>, [">= 1.8.3"])
63 s.add_dependency(%q<simplecov>, [">= 0.5"])
64 end
65 else
66 s.add_dependency(%q<gibberish>, [">= 0"])
67 s.add_dependency(%q<rspec>, [">= 2.8.0"])
68 s.add_dependency(%q<rdoc>, [">= 3.12"])
69 s.add_dependency(%q<bundler>, [">= 1.1.0"])
70 s.add_dependency(%q<jeweler>, [">= 1.8.3"])
71 s.add_dependency(%q<simplecov>, [">= 0.5"])
72 end
73 end
74
Something went wrong with that request. Please try again.