Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

gemspec

  • Loading branch information...
commit 2fea02db0c7562dabb911240b40b8f1811cd08e3 1 parent 6da38a1
@kristianmandrup authored
Showing with 112 additions and 10 deletions.
  1. +6 −9 Gemfile
  2. +37 −0 Gemfile.lock
  3. +1 −1  VERSION
  4. +68 −0 skeleton-rails.gemspec
View
15 Gemfile
@@ -1,14 +1,11 @@
-source "http://rubygems.org"
-# Add dependencies required to use your gem here.
-# Example:
-# gem "activesupport", ">= 2.3.5"
+source :rubygems
# Add dependencies to develop your gem here.
# Include everything needed to run rake, tests, features, etc.
group :development do
- gem "rspec", "~> 2.8.0"
- gem "rdoc", "~> 3.12"
- gem "bundler", "~> 1.0.0"
- gem "jeweler", "~> 1.8.4"
- gem "rcov", ">= 0"
+ gem "rspec", ">= 2.8.0"
+ gem "rdoc", ">= 3.12"
+ gem "bundler", ">= 1.0.0"
+ gem "jeweler", ">= 1.8.3"
+ gem "simplecov",">= 0.5"
end
View
37 Gemfile.lock
@@ -0,0 +1,37 @@
+GEM
+ remote: http://rubygems.org/
+ specs:
+ diff-lcs (1.1.3)
+ git (1.2.5)
+ jeweler (1.8.4)
+ bundler (~> 1.0)
+ git (>= 1.2.5)
+ rake
+ rdoc
+ json (1.7.5)
+ multi_json (1.3.6)
+ rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
+ rspec (2.11.0)
+ rspec-core (~> 2.11.0)
+ rspec-expectations (~> 2.11.0)
+ rspec-mocks (~> 2.11.0)
+ rspec-core (2.11.1)
+ rspec-expectations (2.11.2)
+ diff-lcs (~> 1.1.3)
+ rspec-mocks (2.11.2)
+ simplecov (0.6.4)
+ multi_json (~> 1.0)
+ simplecov-html (~> 0.5.3)
+ simplecov-html (0.5.3)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ bundler (>= 1.0.0)
+ jeweler (>= 1.8.3)
+ rdoc (>= 3.12)
+ rspec (>= 2.8.0)
+ simplecov (>= 0.5)
View
2  VERSION
@@ -1 +1 @@
-0.0.0
View
68 skeleton-rails.gemspec
@@ -0,0 +1,68 @@
+# Generated by jeweler
+# DO NOT EDIT THIS FILE DIRECTLY
+# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = "skeleton-rails"
+ s.version = "0.1.0"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Kristian Mandrup"]
+ s.date = "2012-08-28"
+ s.description = "TODO: longer description of your gem"
+ s.email = "kmandrup@gmail.com"
+ s.extra_rdoc_files = [
+ "LICENSE.txt",
+ "README.md"
+ ]
+ s.files = [
+ ".document",
+ ".rspec",
+ "Gemfile",
+ "Gemfile.lock",
+ "LICENSE.txt",
+ "README.md",
+ "Rakefile",
+ "VERSION",
+ "lib/skeleton-rails.rb",
+ "spec/spec_helper.rb",
+ "vendor/assets/images/icons/skeleton/apple-touch-icon-114x114.png",
+ "vendor/assets/images/icons/skeleton/apple-touch-icon-72x72.png",
+ "vendor/assets/images/icons/skeleton/apple-touch-icon.png",
+ "vendor/assets/images/icons/skeleton/favicon.ico",
+ "vendor/assets/stylesheets/skeleton/base.css",
+ "vendor/assets/stylesheets/skeleton/layout.css",
+ "vendor/assets/stylesheets/skeleton/skeleton.css"
+ ]
+ s.homepage = "http://github.com/kristianmandrup/skeleton-rails"
+ s.licenses = ["MIT"]
+ s.require_paths = ["lib"]
+ s.rubygems_version = "1.8.24"
+ s.summary = "TODO: one-line summary of your gem"
+
+ if s.respond_to? :specification_version then
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_development_dependency(%q<rspec>, [">= 2.8.0"])
+ s.add_development_dependency(%q<rdoc>, [">= 3.12"])
+ s.add_development_dependency(%q<bundler>, [">= 1.0.0"])
+ s.add_development_dependency(%q<jeweler>, [">= 1.8.3"])
+ s.add_development_dependency(%q<simplecov>, [">= 0.5"])
+ else
+ s.add_dependency(%q<rspec>, [">= 2.8.0"])
+ s.add_dependency(%q<rdoc>, [">= 3.12"])
+ s.add_dependency(%q<bundler>, [">= 1.0.0"])
+ s.add_dependency(%q<jeweler>, [">= 1.8.3"])
+ s.add_dependency(%q<simplecov>, [">= 0.5"])
+ end
+ else
+ s.add_dependency(%q<rspec>, [">= 2.8.0"])
+ s.add_dependency(%q<rdoc>, [">= 3.12"])
+ s.add_dependency(%q<bundler>, [">= 1.0.0"])
+ s.add_dependency(%q<jeweler>, [">= 1.8.3"])
+ s.add_dependency(%q<simplecov>, [">= 0.5"])
+ end
+end
+
Please sign in to comment.
Something went wrong with that request. Please try again.