Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Mindre opdateringer + oprydning i wireless.sh

  • Loading branch information...
commit d750ee0f18c7ee0565ed9dfb2d9f8cfe4e20e8fa 1 parent fd6c4e3
@Idolf Idolf authored
View
3  home/user/.vimrc
@@ -16,3 +16,6 @@ nnoremap <C-y> :%y +<CR>
vnoremap <C-y> "+y
nnoremap <C-p> o<Esc>"+p
inoremap <C-p><Esc>x"+pa
+
+autocmd FileType html set shiftwidth=2
+autocmd FileType html set tabstop=2
View
1  home/user/.xmodmap
@@ -11,6 +11,7 @@ keycode 35 = asciicircum asciitilde dead_circumflex dead_tilde dead_diaeresis d
! Den er blot valgt, fordi den ikke gør noget. Det er Alt-modifieren, som udløser genveje i diverse programmer, ikke Alt_R
keycode 66 = Meta_R
+! keycode 66 = Caps_Lock
! Jeg vil gerne have Mode_switch på caps-lock tasten
keycode 135 = Mode_switch
View
2  home/user/bin/dzenheader
@@ -17,7 +17,7 @@ fwireless() {
wirelesscachetime=0
fi
- if iwconfig | grep ESSID | grep -q "off/any"; then
+ if iwconfig | grep ESSID | egrep -q -e "off/any" -e "\\x[0-9A-F]{2}"; then
wirelessbar=""
essid=""
else
View
6 home/user/bin/tvconnect
@@ -44,10 +44,10 @@ for DIS in `xrandr | grep -o "^[A-Z][A-Z1-9]\+"`; do
xrandr --output $DIS --off
else
- if [ " $1" != " " ]; then
- chooseMode $DIS
- else
+ if [ " $1" = " " ]; then
xrandr --output $DIS --auto
+ else
+ chooseMode $DIS
fi
xrandr --output $DIS --pos "$CURWIDTH"x0
View
61 packagelist
@@ -48,10 +48,13 @@ bsdutils install
build-essential install
busybox-initramfs install
busybox-static install
+byobu install
bzip2 install
ca-certificates install
ca-certificates-java install
cabextract install
+camlp4 install
+camlrunm install
cdrdao install
cli-common install
clive install
@@ -71,6 +74,7 @@ cpio install
cpp install
cpp-4.1 install
cpp-4.4 install
+cpu-checker install
cron install
cryptsetup install
cups install
@@ -131,6 +135,8 @@ esound-common install
ethtool install
evince install
exfalso install
+exiv2 install
+extract install
f-spot install
fakeroot install
fancontrol install
@@ -188,6 +194,7 @@ gimp-data install
gimp-plugin-registry install
git-core install
gksu install
+global install
gnome-doc-utils install
gnome-icon-theme install
gnome-keyring install
@@ -224,6 +231,8 @@ gstreamer0.10-pulseaudio install
gstreamer0.10-x install
gtkevemon install
guile-1.6-libs install
+guile-1.8 install
+guile-1.8-libs install
gvfs install
gvfs-backends install
gvfs-bin install
@@ -236,8 +245,6 @@ hicolor-icon-theme install
hostname install
hpijs install
html2text install
-hunspell-en-ca install
-hunspell-en-us install
ia32-libs install
ibus install
ibus-anthy install
@@ -260,6 +267,7 @@ iptables install
iputils-arping install
iputils-ping install
iputils-tracepath install
+ipython install
irqbalance install
iso-codes install
jarwrapper install
@@ -280,8 +288,6 @@ language-pack-en-base install
language-pack-gnome-en install
language-pack-gnome-en-base install
language-selector-common install
-language-support-en install
-language-support-writing-en install
laptop-detect install
laptop-mode-tools install
latex-beamer install
@@ -314,6 +320,7 @@ lib32z1 install
liba52-0.7.4 install
libaa1 install
libacl1 install
+libafterimage0 install
libanthy0 install
libao2 install
libapparmor-perl install
@@ -453,6 +460,7 @@ libdrm-radeon1 install
libdrm2 install
libdv4 install
libdvbpsi5 install
+libdvdcss2 install
libdvdnav4 install
libdvdread4 install
libebml0 install
@@ -472,9 +480,12 @@ libevent-1.4-2 install
libevview2 install
libexempi3 install
libexif12 install
+libexiv2-6 install
libexpat1 install
libexpat1-dev install
libexpect-perl install
+libextractor-plugins install
+libextractor1c2a install
libfaac0 install
libfaad2 install
libffi-dev install
@@ -726,6 +737,7 @@ libmysqlclient16 install
libnautilus-burn4 install
libnautilus-extension1 install
libncurses5 install
+libncurses5-dev install
libncursesw5 install
libndesk-dbus-glib1.0-cil install
libndesk-dbus1.0-cil install
@@ -935,11 +947,11 @@ libwildmidi0 install
libwmf0.2-7 install
libwnck-common install
libwnck22 install
-libwpd8c2a install
-libwps-0.1-1 install
libwrap0 install
libwww-curl-perl install
libwww-perl install
+libwxbase2.8-0 install
+libwxgtk2.8-0 install
libx11-6 install
libx11-data install
libx11-dev install
@@ -1018,6 +1030,9 @@ libxxf86dga1 install
libxxf86misc1 install
libxxf86vm1 install
libzephyr4 install
+lilypond install
+lilypond-data install
+lilypond-doc install
linux-firmware install
linux-firmware-nonfree install
linux-generic install
@@ -1025,9 +1040,12 @@ linux-headers-2.6.32-19 install
linux-headers-2.6.32-19-generic install
linux-headers-2.6.32-21 install
linux-headers-2.6.32-21-generic install
+linux-headers-2.6.32-24 install
+linux-headers-2.6.32-24-generic install
linux-headers-generic install
linux-image-2.6.32-19-generic install
linux-image-2.6.32-21-generic install
+linux-image-2.6.32-24-generic install
linux-image-generic install
linux-libc-dev install
linux-sound-base install
@@ -1057,6 +1075,8 @@ mawk install
medibuntu-keyring install
memtest86+ install
mencoder install
+mercurial install
+mercurial-common install
mesa-utils install
mime-support install
min12xxw install
@@ -1065,6 +1085,7 @@ module-init-tools install
mono-2.0-gac install
mono-gac install
mono-runtime install
+mosml install
mount install
mountall install
mplayer install
@@ -1074,9 +1095,7 @@ musixlyr install
musixtex install
musixtex-slurps install
myspell-da install
-myspell-en-au install
-myspell-en-gb install
-myspell-en-za install
+myspell-en-us install
mysql-client-5.1 install
mysql-client-core-5.1 install
mysql-common install
@@ -1108,16 +1127,18 @@ nvidia-96-modaliases install
nvidia-common install
nvidia-current-modaliases install
obex-data-server install
+ocaml install
+ocaml-base install
+ocaml-base-nox install
+ocaml-interp install
+ocaml-nox install
odbcinst install
odbcinst1debian1 install
openoffice.org-base-core install
openoffice.org-calc install
openoffice.org-common install
openoffice.org-core install
-openoffice.org-emailmerge install
-openoffice.org-math install
openoffice.org-style-galaxy install
-openoffice.org-writer install
openssh-client install
openssh-server install
openssl install
@@ -1161,6 +1182,8 @@ pulseaudio install
pulseaudio-esound-compat install
pulseaudio-module-x11 install
pulseaudio-utils install
+putty install
+putty-tools install
python install
python-appindicator install
python-apport install
@@ -1175,10 +1198,12 @@ python-dbus install
python-debian install
python-django install
python-feedparser install
+python-foolscap install
python-gconf install
python-gdata install
python-gdbm install
python-glade2 install
+python-gmpy install
python-gnome2 install
python-gnomecanvas install
python-gnupginterface install
@@ -1196,12 +1221,14 @@ python-minimal install
python-musicbrainz install
python-mutagen install
python-mysqldb install
+python-newt install
python-notify install
python-numpy install
python-oauth install
python-ogg install
python-openssl install
python-pam install
+python-pexpect install
python-pkg-resources install
python-problem-report install
python-pygame install
@@ -1214,12 +1241,14 @@ python-software-properties install
python-support install
python-twisted-bin install
python-twisted-core install
+python-twisted-names install
python-twisted-web install
-python-uno install
python-utidylib install
python-vte install
python-wadllib install
python-webkit install
+python-wxgtk2.8 install
+python-wxversion install
python-xapian install
python-xdg install
python-xkit install
@@ -1233,6 +1262,7 @@ radeontool install
rarian-compat install
readline-common install
realpath install
+rlwrap install
rpm install
rpm-common install
rpm2cpio install
@@ -1241,9 +1271,11 @@ rsyslog install
rtkit install
ruby install
ruby1.8 install
+rxvt-unicode install
samba-common install
samba-common-bin install
sat4j install
+screen install
scrollkeeper install
scrot install
sdparm install
@@ -1452,6 +1484,7 @@ unrar install
unzip install
update-inetd install
update-manager-core install
+update-notifier-common install
upower install
upstart install
ure install
@@ -1473,8 +1506,6 @@ vlc-nox install
vlc-plugin-pulse install
w3m install
w64codecs install
-wamerican install
-wbritish install
wdanish install
webcamstudio install
wget install
View
17 usr/local/bin/wireless.sh
@@ -1,12 +1,8 @@
#!/bin/sh
-# eduroam skal køres fra en terminal
-#if [ -z $TERM ]; then
-# gnome-terminal -e ~/bin/eduroam.sh &
-# exit 0
-#fi
+INTERFACE=wlan0
-# Og skal køres som root
+# Needs root
if [ `whoami` != "root" ]; then
if [ -z " $TERM" ]; then
gksudo $0
@@ -17,15 +13,18 @@ if [ `whoami` != "root" ]; then
fi
-# Genererer /etc/wpa_supplicant.conf ud fra de filer der ligger i
-# /etc/wpa_supplicant/conf.d
+# Generates combined config file for wpa_supplicant
cat /etc/wpa_supplicant/conf.d/* > /etc/wpa_supplicant.conf
# make sure we have a clean environment
+if [ -e /etc/init.d/network-manager ]; then
+ service network-manager stop
+fi
killall wpa_supplicant
killall dhclient
-if [ `hostname` = "phobetor" ]; then
+# the iwlagn driver sometimes becomes corrupted - reload it to be safe
+if lsmod | grep -q "^iwlagn "; then
modprobe -r iwlagn
modprobe iwlagn
fi
Please sign in to comment.
Something went wrong with that request. Please try again.