Commits on Aug 6, 2012
  1. Update Contributions/Using

    For a fresh homebrew install (never updated) brew pull will not work. Need to brew update at least once first.
    skl committed with josegonzalez Aug 6, 2012
Commits on Aug 5, 2012
  1. Specifying right phpize for brewed PHP

    Installing extensions when the phpize in $PATH is incorrect for that
    extension will result in an InvalidPhpizeError. Those without PHP in
    their $PATH at all will recieve a UnsupportedPhpApiError, since we
    cannot detect `phpize`.
    Currently supported are PHP53 and PHP54. Support for other versions
    should update line 34 of abstract-php-extension.rb to include the
    PHP API Version.
    When installing against a Homebrew version of PHP that is not
    currently linked, it is possible to circumvent the path using the
    `--with-homebrew-php` argument.
    Note that calling `system "phpize"` will result in not using the
    proper phpize. Instead, `safe_phpize` should be used instead.
    Closes #113
    Closes #156
    Closes #173
    josegonzalez committed Aug 5, 2012
  2. Extend AbstractPhpExtension in all PHP extensions

    - For all extensions, create a config file ext-{extension}.ini in conf.d
    - Updated README to reflect changes of adding AbstractPhp5
    - Made AbstractPhp5 more flexible for version detection
    - Fixed detection of php version as in php_branch
    - added config_scandir_path.mkpath before calling .write(config_file)
    - added option extension_type to prevent redefining config_file
    - changed config_file overwrite to call parent
    - moved check of option --without-config-file in each formula
      because of audit errors and added a check if config file exists
    Closes #136. Closes #152
    josegonzalez committed Aug 5, 2012
Commits on Aug 4, 2012
  1. Bugs => Common Issues

    josegonzalez committed Aug 4, 2012
  2. Documented a common 'bug' in Mountain Lion concerning png.h and X11. …

    …Closes #199, #188, #175 and probably others
    josegonzalez committed Aug 4, 2012
  3. updated php to 5.3.15

    BrianGilbert committed with josegonzalez Aug 2, 2012
  4. Adding twig extension

    leek committed with josegonzalez Aug 1, 2012
  5. Adding igbinary extension

    leek committed with josegonzalez Aug 1, 2012
  6. Add libmysql as an install-time option for PHP 5.3

    This patch adds a '--with-libmysql' build option for users who need the
    old-style libmysql client library instead of the newer mysqlnd.
    kstrauser committed with josegonzalez Jul 26, 2012
  7. Allow building with the homebrew version of openssl

    This change allows you to install with the --brewed-openssl option to
    build and use the current 1.0.1c version of openssl that is available
    in the main Homebrew repository.
    We need this because of immediate segfaulting of PHP when connecting to
    a NTLM protected .NET webservice over HTTPS. This is solved when
    updating to this openssl version.
    We figured this out when it al worked just fine on a recent Ubuntu, and
    on our OSX dev environments when we used http, but when switching to
    https the segfaults started.
    roderik committed with josegonzalez Jul 26, 2012
  8. now using php 5.4.5

    Andrew Ellis committed with josegonzalez Jul 26, 2012
  9. Update

    Added note on how to see the list of configuration options.
    drx777 committed with josegonzalez Jul 25, 2012
Commits on Jul 14, 2012
  1. added fpm.d include path

    josegonzalez committed Jul 14, 2012