Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

dependencies are not installed with comparison >= in dependencies #12

Open
vvoovv opened this Issue May 21, 2012 · 0 comments

Comments

Projects
None yet
1 participant

vvoovv commented May 21, 2012

kriszyp-cpm-v0.1.4-0-gb48af56

Package: cbtree https://github.com/pjekel/cbtree (currently the last one at packages.dojofoundation.org)

cbtree depends on dojo and dijit in the following way:
"dependencies": {
"dojo" : ">= 1.7",
"dijit" : ">= 1.7"
}

I tried to install cbtree in an empty directory
dojo and dijit aren't installed.

Here is the output of cpm:

Installing cbtree
Downloading http://packages.dojofoundation.org/cbtree
Downloading http://packages.dojofoundation.org/archives/https$3A$2F$2Fgithub.com$2Fpjekel$2Fcbtree$2Fzipball$2Fv0.9.0
Unzipping http://packages.dojofoundation.org/archives/https$3A$2F$2Fgithub.com$2Fpjekel$2Fcbtree$2Fzipball$2Fv0.9.0
Done unzipping

Installing dependency: dojo
Installing dojo version >= 1.7 or newer
Downloading http://packages.dojofoundation.org/dojo
Already current

Installing dependency: dijit
Installing dijit version >= 1.7 or newer
Downloading http://packages.dojofoundation.org/dijit
Already current

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment