Permalink
Switch branches/tags
Commits on Jun 2, 2017
  1. Adds --insecure to cockroachdb client command

    cdrage committed Jun 2, 2017
    Cockroach errors out when using said command:
    
    ```shell
    ▶  kubectl run -it --rm cockroach-client --image=cockroachdb/cockroach --restart=Never --command -- ./cockroach sql --host cockroachdb-public
    Waiting for pod default/cockroach-client to be running, status is Pending, pod ready: false
    Waiting for pod default/cockroach-client to be running, status is Pending, pod ready: false
    Waiting for pod default/cockroach-client to be running, status is Pending, pod ready: false
    If you don't see a command prompt, try pressing enter.
                                                          Error attaching, falling back to logs: unable to upgrade connection: container cockroach-client not found in pod cockroach-client_default
    Error: problem using security settings, did you mean to use --insecure?: problem with CA certificate: not found
    Failed running "sql"
    Waiting for pod default/cockroach-client to terminate, status is Running
    pod "cockroach-client" deleted
    ```
    
    This PR updates the README.md to include --insecure in the client command
Commits on Jul 14, 2016
  1. Warn when missing cloud-provider on kube controller

    cdrage committed Jul 14, 2016
    This commit warns the user / gives better information that when using
    --cloud-provider="" on kube-controller, that services such as
    LoadBalancer will not work.
    
    However, despite the error, kube-controller will still run as normal.
    
    Fixes #12716
    Fixes #11172
    Fixes #27085