Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

external-dependencies-version: Improve error message #80051

Closed
cblecker opened this issue Jul 11, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@cblecker
Copy link
Member

commented Jul 11, 2019

What would you like to be added:
The current error message is vague and could be improved.

build/dependencies.yaml indicates <dependency-name> should be at <version>, but the following files did not match that version:
  ... list of mismatched files
if you are changing the version of <dependency>, make sure all of the following files are updated with the new version:
  build/dependencies.yaml
  ... list of files for <dependency>

(credit to @liggitt)

Why is this needed:
Improve contributor experience, make it easier to identify change to be fixed.

/cc @justaugustus @yastij @kubernetes/sig-release

@yastij

This comment has been minimized.

Copy link
Member

commented Jul 11, 2019

/assign

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.