Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Cannot install ruby-oci8 together with ruby-2.0.0-preview2 32 bit #25

Closed
aboltart opened this Issue Dec 3, 2012 · 2 comments

Comments

Projects
None yet
2 participants

aboltart commented Dec 3, 2012

I have Mac OS 10.8.2
I have Oracle Instant Client: 32-bit - 10.2.0.4.0
Using RVM I installed ruby-2.0.0-preview2 32 bit version

When I install ruby-oci8 I got following error: https://gist.github.com/4193407

All is fine if I use ruby 1.9.3-p327 32 bit

@kubo kubo closed this in 2edf4e6 Dec 3, 2012

Owner

kubo commented Dec 3, 2012

Thank you for your report.
You can fix it as follows or use latest github master.

gem unpack ruby-oci8-2.1.3.gem
cd ruby-oci8-2.1.3 
vi ext/oci8/oraconf.rb    <-- add "# coding: ascii" at the top of the file.
gem build ruby-oci8.gemspec
gem install ./ruby-oci8-2.1.3.gem

aboltart commented Dec 3, 2012

Thanks works fine

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment