Skip to content
Pluggable ESLint configs for ECMAScript Next, Node.js and React Native that you can import and extend
JavaScript
Branch: master
Clone or download
kunalgolani Merge pull request #17 from kunalgolani/dependabot/npm_and_yarn/packa…
…ges/recommended/eslint-utils-1.4.3

Bump eslint-utils from 1.3.1 to 1.4.3 in /packages/recommended
Latest commit 2ea9f48 Dec 27, 2019

README.md

eslint-config

Pluggable ESLint configs for ECMAScript Next, Node.js and React Native that you can import, extend and override

Join the chat at https://gitter.im/kunalgolani/eslint-config npm version npm downloads GitHub issues Deps Dev Deps

Usage

See individual packages

To add a git-hook to your commits, consider using husky

npm install --save-dev husky

And in your package.json:

  "scripts": {
    "precommit": "eslint ."
  }

Config

These configs are biased and opinionated, and err on the side of too many rules instead of too few. Think of them as a superset of your repo's lint config, and discard what you don't like in them. It's easy to override and disable the rules you find inconvenient.

You can’t perform that action at this time.