Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Dependency lint finds multiple version of ember-compatibility-helpers #127

Closed
kriswill opened this issue Apr 16, 2018 · 3 comments
Closed

Dependency lint finds multiple version of ember-compatibility-helpers #127

kriswill opened this issue Apr 16, 2018 · 3 comments

Comments

@kriswill
Copy link

@kriswill kriswill commented Apr 16, 2018

When running ember test on my app, it complains about ember-compatibility-helpers consumed from deep within ember-attacher.

not ok 1 Chrome 65.0 - DependencyLint ember-compatibility-helpers
---
message: >
  Expected only one version of ember-compatibility-helpers, but found
  @org/app
  └─┬ @org/v0-engine
    └─┬ @org/presentation
      └─┬ ember-attacher
        └─┬ ember-popper
          ├── ember-compatibility-helpers@0.1.3
          ├─┬ @ember-decorators/argument
          │ └── ember-compatibility-helpers@1.0.0-beta.2
          └─┬ ember-decorators
            ├─┬ @ember-decorators/component
            │ └─┬ @ember-decorators/utils
            │   └── ember-compatibility-helpers@1.0.0-beta.1
            ├─┬ @ember-decorators/controller
            │ └─┬ @ember-decorators/utils
            │   └── ember-compatibility-helpers@1.0.0-beta.1
            ├─┬ @ember-decorators/data
            │ └─┬ @ember-decorators/utils
            │   └── ember-compatibility-helpers@1.0.0-beta.1
            ├─┬ @ember-decorators/object
            │ ├── ember-compatibility-helpers@0.1.3
            │ └─┬ @ember-decorators/utils
            │   └── ember-compatibility-helpers@1.0.0-beta.1
            └─┬ @ember-decorators/service
              └─┬ @ember-decorators/utils
                └── ember-compatibility-helpers@1.0.0-beta.1
@kriswill

This comment has been minimized.

Copy link
Author

@kriswill kriswill commented Apr 16, 2018

using:

// config/dependency-lint.js
module.exports = {
  allowedVersions: {
    // ember-attacher is using various versions
    'ember-compatibility-helpers': '*'
  }
};

temporary work-around for dependency-lint, by suspending the constraints for this add-on.

@kybishop

This comment has been minimized.

Copy link
Owner

@kybishop kybishop commented Apr 17, 2018

Thanks @kriswill! Will see about adding a version bump downstream

@kybishop

This comment has been minimized.

Copy link
Owner

@kybishop kybishop commented Oct 12, 2018

Closed via #152

@kybishop kybishop closed this Oct 12, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.