Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Could not find module `ember-compatibility-helpers` imported from `@ember-decorators/argument/-debug/utils/validation-decorator` #151

Closed
mhluska opened this issue Oct 3, 2018 · 3 comments

Comments

@mhluska
Copy link

@mhluska mhluska commented Oct 3, 2018

I've been seeing this error in the console after a mass update of versions after upgrading to Node 10. The only dependency I have that uses ember-decorators (and ember-popper) is ember-attacher. I've also posted over there asking about this issue: ember-decorators/ember-decorators#285

Before this error, I get an error related to ember-popper:

"Error: Assertion Failed: Expected component:ember-popper to resolve to an Ember.Component but instead it was [object Object].
    at new EmberError (http://localhost:4200/assets/vendor.js:28634:25)
    at assert (http://localhost:4200/assets/vendor.js:28877:15)
    at validateType (http://localhost:4200/assets/vendor.js:28260:71)
    at Class.resolve (http://localhost:4200/assets/vendor.js:28085:35)
    at _resolve (http://localhost:4200/assets/vendor.js:26063:36)
    at Registry.resolve (http://localhost:4200/assets/vendor.js:25766:21)
    at Registry.resolve (http://localhost:4200/assets/vendor.js:25770:55)
    at Container.factoryFor (http://localhost:4200/assets/vendor.js:25328:121)
    at Class.factoryFor (http://localhost:4200/assets/vendor.js:52176:33)
    at Class.componentFor [as _super] (http://localhost:4200/assets/vendor.js:59011:20)"

I'm honestly not sure if the issue here is ember-decorators, ember-popper or ember-attacher so apologies if this is the wrong place to post.

My versions:

ember-decorators 2.5.1
ember-compatibility-helpers 1.1.0
ember-attacher 0.13.7
ember-popper 0.9.1
ember-cli 3.4.3
ember-data 3.0.2
node v10.110

@vivian-ho

This comment has been minimized.

Copy link

@vivian-ho vivian-ho commented Oct 3, 2018

Same issues, we're on ember-cli 2.18.2, ember-attacher 0.13.6

@kybishop

This comment has been minimized.

Copy link
Owner

@kybishop kybishop commented Oct 11, 2018

This will be addressed as soon as I can release ember-popper and then bump the dependency here

@kybishop

This comment has been minimized.

Copy link
Owner

@kybishop kybishop commented Oct 12, 2018

Closed via #152

@kybishop kybishop closed this Oct 12, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.