Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Getting error on build about AFHTTPClient.h #102

Closed
smitssmiling opened this Issue Dec 12, 2013 · 3 comments

Comments

3 participants

Hi,

I just installed Cocoapods and trying to add drupal-ios-sdk in my Xcode project. I also followed all the steps that were told on the respective AFNetworking library. But when I try to build my project it gives me error - AFHTTPClient.h file not found.
I see that its being imported in 2 files - DIOSCSRFAFHTTPClient.h and DIOSSession.h
But I dont see any AFHTTPClient.h file under AFNetworking folder under the project's Pod.
Did anyone come across this error?
Any help would be really appreciated.

@ghost

ghost commented Dec 12, 2013

http://stackoverflow.com/questions/16389888/afhttpclient-h-file-not-found

Check this question on Stack Overflow -- I followed this and fixed a similar issue.

Hi, Thank you for helping. I realized that I was using 2.0 Version of AFNetworking library. But the latest version of drupal-ios-sdk is compatible with older versions of AFNetworking ( version 1.x and older ). The newer version of AFNetworking library (2.0) doesn't have AFHTTPClient.h class, and since was the error. Check out the Requirements section - https://github.com/AFNetworking/AFNetworking#requirements of AFNetworking before using it.
So long story short, I installed the pod for my xcode project with 1.x AFNetworking version and waala..!!! No more errors.

Owner

kylebrowning commented Jun 26, 2014

2.0 has been added to the project now.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment