Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error when creating namespace with istio disabled option #1352

Closed
kwiatekus opened this issue Oct 29, 2019 · 0 comments
Assignees
Labels

Comments

@kwiatekus
Copy link
Collaborator

@kwiatekus kwiatekus commented Oct 29, 2019

Description

When I try to create a new namespace and select to disable istio side-car injection option, the label that gets appended has a wrong format:
0=istio-injection=disabled

Screen Shot 2019-10-29 at 14 20 49

This is resulting in validation error.

Screen Shot 2019-10-29 at 14 20 58

Expected result

When Disable istio side car.. option is selected, a proper label is appended (istio-injection=disabled)

Actual result

Label with 0=... prefix is appended - which causes validation error

Steps to reproduce

  1. Log in to console.
  2. Click Create Namespace button
  3. Select to disable Istio side-car

Workaround
In order to disable side-car injection for your new namespace, you could add the label manually, instead of selecting the checkbox:
istio-injection=disabled

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
2 participants
You can’t perform that action at this time.