vCard 3 validator, class and utility functions
Python Shell Java Makefile OCaml

README.markdown

vCard module

Build Status

This program can be used for strict validation and parsing of vCards. It currently supports vCard 3.0 (RFC 2426).

Additional scripts:

Installation / upgrade

sudo pip install --upgrade vcard

Examples

Development

Download:

git clone --recurse-submodules https://github.com/l0b0/vcard.git

Test:

make test

To test a specific Python version:

make PYTHON_VERSION=3.5.1 test

Test requirements:

  • gcc
  • gpg
  • tar
  • make
  • openssl development headers/libraries
  • pip
  • wget
  • zlib development headers/libraries