Skip to content
Permalink
Browse files

requirements: update pytest and remove pytest-runner

pytest-runner has been deprecated, so remove it from setup.py.

Signed-off-by: Jan Luebbe <jlu@pengutronix.de>
  • Loading branch information...
jluebbe committed Oct 27, 2019
1 parent b3a7735 commit a9679c881e8ac822cdccd0b9ac4c95ee82a0a0b7
Showing with 5 additions and 7 deletions.
  1. +3 −4 dev-requirements.txt
  2. +1 −1 requirements.txt
  3. +1 −2 setup.py
@@ -1,8 +1,7 @@
pytest-cov==2.7.1
pytest-cov==2.8.1
pytest-isort==0.3.1
pytest-mock==1.10.4
pytest-pylint==0.14.0
pytest-runner==4.4
pytest-mock==1.11.2
pytest-pylint==0.14.1
pytest-dependency==0.4.0
yapf==0.28.0
-r doc-requirements.txt
@@ -2,7 +2,7 @@ attrs==19.3.0
jinja2==2.10.1
pexpect==4.7
https://github.com/labgrid-project/pyserial/archive/v3.4.0.1.zip#egg=pyserial
pytest==4.6.3
pytest==5.2.2
pyudev==0.21.0
requests==2.22.0
xmodem==0.4.5
@@ -23,8 +23,7 @@
'modbus': ['pyModbusTCP'],
'graph': ['graphviz'],
},
setup_requires=['pytest-runner', 'setuptools_scm'],
tests_require=['pytest-mock', ],
setup_requires=['setuptools_scm'],
install_requires=[
'attrs>=19.2.0',
'ansicolors',

0 comments on commit a9679c8

Please sign in to comment.
You can’t perform that action at this time.