Permalink
Browse files

requirements: update and pin dependencies

Pin pyyaml to latest version 3.12
Pin attrs to latest version 17.4.0
Update crossbar from 17.8.1.post1 to 17.12.1
Pin pexpect to latest version 4.3.1
Pin pymodbustcp to latest version 0.1.5
Pin pysnmp to latest version 4.4.4
Pin pysnmp-mibs to latest version 0.1.6
Pin pytest to latest version 3.4.0
Pin pytest-cache to latest version 1.0
Pin pytest-cov to latest version 2.5.1
Pin pytest-isort to latest version 0.1.0
Pin pytest-mock to latest version 1.6.3
Pin pytest-pylint to latest version 0.7.1
Pin pytest-runner to latest version 3.0
Pin pyudev to latest version 0.21.0
Pin yapf to latest version 0.20.1
Pin requests to latest version 2.18.4
Pin autobahn to latest version 17.10.1
Pin sphinxcontrib-napoleon to latest version 0.6.1
Pin sphinx to latest version 1.6.7
Pin sphinx_rtd_theme to latest version 0.2.4
Update docutils from 0.13.1 to 0.14

Signed-off-by: Rouven Czerwinski <r.czerwinski@pengutronix.de>
  • Loading branch information...
Emantor committed Jan 24, 2018
1 parent 8cc5b9a commit e278f5085ccf4b431542657b24f6451cfd6c9cb8
Showing with 22 additions and 22 deletions.
  1. +18 −18 dev-requirements.txt
  2. +4 −4 doc-requirements.txt
@@ -1,22 +1,22 @@
PyYAML
attrs>=16.3.0,<17.3.0
crossbar==17.8.1.post1
pexpect
pyModbusTCP
PyYAML==3.12
attrs==17.4.0
crossbar==17.12.1
pexpect==4.3.1
pyModbusTCP==0.1.5
pyserial>=3.3
pysnmp
pysnmp-mibs
pytest
pytest-cache
pytest-cov
pytest-isort
pytest-mock
pytest-pylint
pytest-runner
pysnmp==4.4.4
pysnmp-mibs==0.1.6
pytest==3.4.0
pytest-cache==1.0
pytest-cov==2.5.1
pytest-isort==0.1.0
pytest-mock==1.6.3
pytest-pylint==0.7.1
pytest-runner==3.0
onewire>=0.2
pyudev
yapf
requests
autobahn
pyudev==0.21.0
yapf==0.20.1
requests==2.18.4
autobahn==17.10.1
xmodem>=0.4.5
-r doc-requirements.txt
@@ -1,4 +1,4 @@
sphinxcontrib-napoleon
Sphinx
sphinx_rtd_theme
docutils==0.13.1
sphinxcontrib-napoleon==0.6.1
Sphinx==1.6.7
sphinx_rtd_theme==0.2.4
docutils==0.14

0 comments on commit e278f50

Please sign in to comment.