Skip to content
Permalink
Browse files

requirements: bump crossbar and autobahn to latest

Upstream crossbar has a report with the same "event for publication
[xxx] not in event store" under [1]. But they could not reproduce with
19.1.1, so bump to the latest version.
Crossbar now implicitly requires msgpack, add it as a dependency.
Also bump PyYAML to prevent conflicts.

[1]: crossbario/crossbar#1459

Signed-off-by: Rouven Czerwinski <r.czerwinski@pengutronix.de>
  • Loading branch information...
Emantor authored and jluebbe committed Apr 1, 2019
1 parent ebba485 commit fd596a8e0153f0975801337a8014584ffe65b91c
Showing with 6 additions and 4 deletions.
  1. +1 −0 CHANGES.rst
  2. +3 −2 crossbar-requirements.txt
  3. +2 −2 requirements.txt
@@ -4,6 +4,7 @@ Release 0.3.0 (unreleased)
New Features in 0.3.0
~~~~~~~~~~~~~~~~~~~~~

- Crossbar and autobahn have been updated to 19.3.3 and 19.3.5 respectively.
- The InfoDriver was removed. The functions have been integrated into the
labgridhelper library, please use the library for the old functionality.
- labgrid-client ``write-image`` subcommand: labgrid client now has a
@@ -1,5 +1,6 @@
-r requirements.txt
setuptools>=38.0.0
crossbar==18.12.1
crossbar==19.3.5
# For crossbar
idna==2.5
idna==2.5
msgpack==0.6.1
@@ -6,6 +6,6 @@ pytest==4.0.2
pyudev==0.21.0
requests==2.19.1
xmodem==0.4.5
autobahn==18.12.1
PyYAML==3.13
autobahn==19.3.3
PyYAML==5.1
ansicolors==1.1.8

0 comments on commit fd596a8

Please sign in to comment.
You can’t perform that action at this time.