Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Fix runtime dependencies.

They now correctly specify compatibility with Rails 2.3 and Rails 3.
  • Loading branch information...
commit 9cbab2e53ab82d1e6186814fe9ec47ca2b1e1939 1 parent 9d6debc
@airblade airblade authored
Showing with 14 additions and 15 deletions.
  1. +12 −13 Gemfile.lock
  2. +2 −2 paper_trail.gemspec
View
25 Gemfile.lock
@@ -1,21 +1,20 @@
PATH
remote: .
specs:
- paper_trail (1.5.4)
- actionpack (~> 2.3)
- activerecord (~> 2.3)
- activerecord (~> 2.3)
+ paper_trail (1.5.5)
+ actionpack (>= 2.3)
+ activerecord (>= 2.3)
GEM
remote: http://rubygems.org/
specs:
- actionpack (2.3.5)
- activesupport (= 2.3.5)
- rack (~> 1.0.0)
- activerecord (2.3.5)
- activesupport (= 2.3.5)
- activesupport (2.3.5)
- rack (1.0.1)
+ actionpack (2.3.10)
+ activesupport (= 2.3.10)
+ rack (~> 1.1.0)
+ activerecord (2.3.10)
+ activesupport (= 2.3.10)
+ activesupport (2.3.10)
+ rack (1.1.0)
rake (0.8.7)
shoulda (2.10.3)
sqlite3-ruby (1.3.1)
@@ -24,8 +23,8 @@ PLATFORMS
ruby
DEPENDENCIES
- actionpack (~> 2.3)
- activerecord (~> 2.3)
+ actionpack (>= 2.3)
+ activerecord (>= 2.3)
activesupport (~> 2.3)
bundler (~> 1.0)
paper_trail!
View
4 paper_trail.gemspec
@@ -22,6 +22,6 @@ Gem::Specification.new do |s|
s.add_development_dependency 'activesupport', '~> 2.3'
s.add_development_dependency 'sqlite3-ruby', '~> 1.2'
- s.add_dependency 'activerecord', '~> 2.3'
- s.add_dependency 'actionpack', '~> 2.3'
+ s.add_dependency 'activerecord', '>= 2.3'
+ s.add_dependency 'actionpack', '>= 2.3'
end
Please sign in to comment.
Something went wrong with that request. Please try again.