Skip to content


Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Server automation framework and application
Failed to load latest commit information.
acceptance Merge branch '2.6.x' into 2.7.x
autotest Fixing the watchr script
bin [#4196] Move the docs into the source directory structure
conf (#8301) Red Hat spec file for 2.7.2rc1 won't work
examples (#6338) Remove unused version control tags
ext (#6395) Add extpuppet help, eval, and interfaces
man Maint: Update static man pages for 2.7.0
spec Merge branch '2.7rc'
tasks/rake Maint: Update static man page generator for Faces.
test Merge branch '2.7rc'
.gitignore maint: Add vim swap files to .gitignore
.testseries Updated test series
CHANGELOG Updated CHANGELOG for 2.7.4rc3 Add document outlining preferred contribution methods
LICENSE Fixed #5684 - Move to Apache 2.0 license Merge branch '2.6.x' into 2.7.x
Rakefile maint: use chdir rather than depend on bash for win32
install.rb (#9174) Provide a helpful error when missing a gem and installing on …


Puppet, an automated administrative engine for your Linux and Unix systems, performs administrative tasks (such as adding users, installing packages, and updating server configurations) based on a centralized specification.

Documentation (and detailed installation instructions) can be found online at the Puppet Docs site.


Generally, you need the following things installed:

  • A supported Ruby version. Ruby 1.8.5, 1.8.7, and 1.9.2 are fully supported (with a handful of known issues under 1.9.2); Ruby 1.8.1 is supported on a best-effort basis for agent use only. Other versions of Ruby are used at your own risk, and Ruby 1.8.6, 1.9.0, and 1.9.1 are not recommended for compatibility reasons.

  • The Ruby OpenSSL library. For some reason, this often isn't included in the main ruby distributions. You can test for it by running 'ruby -ropenssl -e "puts :yep"'. If that errors out, you're missing the library.

    If your distribution doesn't come with the necessary library (e.g., on Debian and Ubuntu you need to install libopenssl-ruby), then you'll probably have to compile Ruby yourself, since it's part of the standard library and not available separately. You could probably just compile and install that one library, though.

  • Facter => 1.5.1 (available via your package manager or from the Facter site.


See LICENSE file.


Please log tickets and issues at our Projects site

Something went wrong with that request. Please try again.