javascript bundles always produce files with zero bytes #50

Closed
ingebretsen opened this Issue Dec 27, 2012 · 8 comments

Comments

Projects
None yet
2 participants

For reference, you can try the example site in the root of the main branch. I've tried it two computer (both macs, Mountain Lion and Lion) and every time the css files are generated properly but all.js has zero bytes. I've seen the same behavior on my own site.

Owner

laktek commented Dec 28, 2012

Can you check and let me know the version of Uglify-js installed on your machines?

Looks like its version 1.1.69 on my Mountain Lion machine. I don't have
access to the other machine right now.

Do think that's the issue? Let me know how else I can help. Thanks for
checking into this.

thinkpixellab.com / nerdplusart.com http://nerdplusart.com/blog /
@ingebretsen http://twitter.com/ingebretsen

On Thu, Dec 27, 2012 at 6:30 PM, Lakshan Perera notifications@github.comwrote:

Can you check and let me know the version of Uglify-jshttps://npmjs.org/package/uglify-jsinstalled on your machines?


Reply to this email directly or view it on GitHubhttps://github.com/laktek/punch/issues/50#issuecomment-11723811.

Owner

laktek commented Dec 28, 2012

Punch requires Uglify-Js version above 1.3.3. Can you give a try after upgrading the package?

Sorry...I got it wrong. 1.1.69 is my npm version number. Looks like I've
got uglify 2.2.2.

Should I try downgrading?

thinkpixellab.com / nerdplusart.com http://nerdplusart.com/blog /
@ingebretsen http://twitter.com/ingebretsen

On Thu, Dec 27, 2012 at 6:41 PM, Lakshan Perera notifications@github.comwrote:

Punch requires Uglify-Js version above 1.3.3. Can you give a try after
upgrading the package?


Reply to this email directly or view it on GitHubhttps://github.com/laktek/punch/issues/50#issuecomment-11723959.

Owner

laktek commented Dec 28, 2012

For the time being, it's better if you can downgrade to 1.3.3.

I'll check if there's an issue with 2.2.2

I'll try that and get back to you. Thanks!

thinkpixellab.com / nerdplusart.com http://nerdplusart.com/blog /
@ingebretsen http://twitter.com/ingebretsen

On Thu, Dec 27, 2012 at 7:47 PM, Lakshan Perera notifications@github.comwrote:

For the time being, it's better if you can downgrade to 1.3.3.

I'll check if there's an issue with 2.2.2


Reply to this email directly or view it on GitHubhttps://github.com/laktek/punch/issues/50#issuecomment-11724706.

Moving to 1.3.3 did the trick!

I had to update the module from inside of /usr/local/share/npm/lib/node_modules/punch

I'm not an npm pro by any means, but that would lead me to believe that punch is not specifying which version of uglify is required during its installation and so a default installation is getting 2.2 (or whatever is latest).

Either way, I'm good now! Thanks for the help.

Owner

laktek commented Jan 5, 2013

Punch is now (from 0.5.12) using Uglify-JS2 for minification. Having the latest version of Uglify-JS installed will not create any issues.

laktek closed this Jan 5, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment