Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Problem Installing Ruby GEM #1

Open
vegarituwall opened this Issue · 6 comments

6 participants

@vegarituwall

design.io@0.2.7 install /Users/javiervega/Desktop/Development Projects/team-rituwall/rituwall/node_modules/design.io
gem install rb-fsevent --no-ri --no-rdoc ; npm install design.io-stylesheets ; npm install design.io-javascripts

ERROR: While executing gem ... (Gem::FilePermissionError)
You don't have write permissions into the /Library/Ruby/Gems/1.8 directory.

@shift

This problem can be overcome by installing RVM or maybe also via "sudo gem install rb-fsevent --no-ri --no-rdoc".

For the most part I'd recommend installing RVM as to not be messing on with the system Ruby install.

Hope that helps.

@kennu

I just ran into this problem while trying to install Tower.js, which depends on design.io. It is very annoying that even after I have installed the gem manually (with sudo), design.io wants to reinstall it without sudo so the install always fails.

@wiber

did you get around it somehow? so far no luck.. still get the error while sudo npm install design.io -g .

@RobGonda

Same problem

@thehydroimpulse

Anyone find a solution? Just came across this problem.

@thehydroimpulse

If anyone is still having this problem here is what fixed it for me: Download the tar ball from github. Browse to where you downloaded it and extract it. Open the packages.json and remove the script key. Compress it back into a tar ball and run this command.

npm install design.io.tar.gz -g

I believe a commit is lined up to remove the script key but it has yet to merge into the main project.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.