Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

`design.io start` fails on fresh global install #7

Open
contentfree opened this Issue · 1 comment

1 participant

@contentfree

Node v0.6.15
NPM 1.1.16

$ design.io start

info: socket.io started



node.js:201
        throw e; // process.nextTick error, or 'error' event on first tick
              ^
node.js:201
        throw e; // process.nextTick error, or 'error' event on first tick
              ^

Error: Cannot find module 'coffee-script'
    at Function._resolveFilename (module.js:332:11)
    at Function._load (module.js:279:25)
    at Module.require (module.js:354:17)
    at require (module.js:370:17)
    at Object.<anonymous> (/Users/dave/open_source/nvm/v0.6.15/lib/node_modules/design.io/node_modules/pathfinder/lib/pathfinder.js:4:3)
    at Object.<anonymous> (/Users/dave/open_source/nvm/v0.6.15/lib/node_modules/design.io/node_modules/pathfinder/lib/pathfinder.js:58:4)
    at Module._compile (module.js:441:26)
    at Object..js (module.js:459:10)
    at Module.load (module.js:348:31)
    at Function._load (module.js:308:12)
Error: Cannot find module 'coffee-script'
    at Function._resolveFilename (module.js:332:11)
    at Function._load (module.js:279:25)
    at Module.require (module.js:354:17)
    at require (module.js:370:17)
    at Object.<anonymous> (/Users/dave/open_source/nvm/v0.6.15/lib/node_modules/design.io/node_modules/pathfinder/lib/pathfinder.js:4:3)
    at Object.<anonymous> (/Users/dave/open_source/nvm/v0.6.15/lib/node_modules/design.io/node_modules/pathfinder/lib/pathfinder.js:58:4)
    at Module._compile (module.js:441:26)
    at Object..js (module.js:459:10)
    at Module.load (module.js:348:31)
    at Function._load (module.js:308:12)

warn: Forever detected script exited with code: 1

coffee-script is not listed as a dependency in design.io's package.json. Should it be?

@contentfree

npm install coffee-script -g fixes it, but if it's a dependency it should be in package.json.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.