New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tooling on Windows always as root #1362

Closed
rabauss opened this Issue Jan 24, 2019 · 2 comments

Comments

Projects
None yet
2 participants
@rabauss
Copy link

rabauss commented Jan 24, 2019

Bug Report

v3.0.0-rc.1 on Windows 10 Pro with Docker 2.0.0.2

name: test
recipe: lamp

Unfortunately, I have not found a suitable issue.
Is it intended or a must that all tooling commands for lando on Windows 10 are executed as root and not as www-data?

For example, with lando ssh I always end up as root on the appserver - even lando ssh --user www-data logs me in as root. The tooling lando composer is also executed as root in the appserver.

Does anyone have the same problems on Windows?

@pirog pirog self-assigned this Jan 28, 2019

@pirog pirog added this to the 3.0.0-rc.2 milestone Jan 28, 2019

@pirog pirog closed this Jan 31, 2019

@pirog

This comment has been minimized.

Copy link
Member

pirog commented Feb 1, 2019

@rabauss this should be fixed in RC2

@rabauss

This comment has been minimized.

Copy link
Author

rabauss commented Feb 3, 2019

yes, looks fine!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment